0

tl;dr: When I left-click (and release) on the VMware Workstation 15 main window near its menu, the mouse unexpectedly grabs and drags the window. This doesn't happen in any other application windows on my Ubuntu Linux desktop (KDE/Plasma). Fixable?

Details:

I'm having a problem in KDE/Plasma (5.5.5) when I click on the VMware Workstation Pro 15 window. If I click on the VMware menu, the mouse grabs and drags the whole window when it shouldn't. (This didn't happen in VMware Workstation 14.) This is under Ubuntu 16.04.6 LTS.

At first, I thought this window behavior might be due to a KDE setting, but VMware Workstation is the only application window with this behavior. It is extremely annoying -- about 20% of the time that I click the VMware window to activate it, I click near the menu bar by accident and start dragging the window around. Argh.

Steps to reproduce:

  1. Locate the main VMware menu (File, Edit, View, VM, Tabs, Help).
  2. Position the mouse pointer to the right of the word "Help" (i.e., in the empty space on the right of the menu bar).
  3. Click AND RELEASE the left mouse button once. When I click near the red dot, the problem happens.
  4. The mouse pointer turns into a "Move" pointer, indicating that the entire VMware window is in "move mode" and will move with the mouse. (This should not happen, because the left mouse button was RELEASED. It should happen only if the left mouse button is clicked and HELD.)
  5. Move the mouse. The entire VMware Workstation application window moves along with the mouse cursor. (This should not happen.)
  6. Clicking and releasing the left mouse button a second time turns off "move mode" and restores the mouse cursor to its proper icon.

Solutions I've already tried:

I already tried this fix (systemsettings->Application Style->Widget Style->Configure->"Drag windows from titlebar only"), but the setting did not affect the problem.

I filed a ticket with VMware but they only said, "KDE is not supported, use Gnome," which is nuts because I've been using KDE with VMware for well over 10 years, and the problem just appeared in VMware Workstation v.15.

Thank you very much for any insights!

0

I upgraded to Ubuntu 18.04 and the problem disappeared.

I also found a workaround in 16.04, but it's a hack. You can check the checkbox View > Customize > Toolbar, which causes the VMware Toolbar to be displayed. The toolbar is overlaid on the menu bar and somehow prevents the problem. This hack works as long as Preferences > Display > Combine toolbar with menubar in windowed mode is checked. If it's unchecked, then the toolbar doesn't overlay the menubar and you'll still have the mouse problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.