I have two MacBooks. One installed Ubuntu 18.04 flawlessly. The other would hang on the Splash Screen for the intial install. So in the grub menu, I pressed 'e' and typed in nomodeset where applicable. That did the trick, and I was able to install Ubuntu. Then I updated the graphics to NVIDIA, rebooted, and now I'm getting a blank screen on boot-up. If I press option + command + r, I'm able to get to the grub menu again (not from the boot USB), and if I press e, I see that nomodeset is already there. I don't understand what to do at this point.

I also tried to start completely over, and press option + power to boot to USB, and my USB drive won't show up in the menu! I tried different USB drives, and same result.


Found the answer to my question here. If I'm installing Ubuntu, then I have to press 'e' and add 'nomodeset' to the grub menu. After it's installed, I have to follow the directions in the link in order to install proper NVIDIA drivers. I actually have LUbuntu installed now, which doesn't require the 'nomodeset' method at all. But I still need to follow the directions to get the proper NVIDIA driver.

I still don't actually know how to get out of the black screen thing apart from reinstalling the OS. Also, I figured out how to get the USB to be detected on boot. I press Control + Option + R + P, then press the power button, and continue holding everything except the power button. The system start-up noise and gray screen will show, and then turn black, and will make the noise and gray screen again as long as I'm holding the key combos. I let it reboot like this about 3-4 times, then shut down. Then I press Option + Power, and see if the USB shows. If it doesn't I try that method again. Eventually, it shows up and I can reinstall the OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.