2

(Edited ~12pm PST May 6th for consolidation and clarity)

I am having similar problems as here and here. The actual product is a cheap Chinese USB to PCIe adapter card or pic of the internal hardware. It appears the only answer with others has been "update your kernel." However on the other posts it appears the hardware was never working at all, no real solution was found, and as I will show I don't believe the Kernel version is the issue. Below I have shown, my system information, the fact that the hardware is initialized, and finally the output when it fails after plugging in a device. I've tried this on kernel v5.0.10 (mainline) and v4.15.0-48.51. I have also tested it on Lubuntu 18.04, and 19.04. I have tested the PCIe card with a USB keyboard (generic so..1.1/2.0?), and both a self powered and USB powered USB 3.0 external hard drive. All three devices exhibit the same failure mode.

Here are a list of commands to use if anyone is facing similar issues. I have listed my results from these commands at the bottom of this.

uname -a this returns your current kernel version

cat /etc/lsb-release this returns your distro version

sudo dmidecode this returns the status of all system hardware (like a PCIe slot)

lspci -nn this will return the status of all hardware on the PCI bus (filter through this intuitively)

dmesg | grep xhci this will show the status messages and list things like a failure

The following is intended mostly for Devs. I am an amateur hardware 'enthusiast' and would have no problem (attempting) troubleshooting the hardware side of this, but my software skills are weak. My PCIe adapter has an uPD720202. The datasheet for this is not directly available from Renesas without first creating an account on their website. However, the complete datasheet is available through parts distributors such as Mouser. This document has pinouts and timing diagrams but no application notes. After looking for potential application notes floating around the web I came across the following... (be aware this is a PDF download file link (the author of the PDF matches the host site "stonegroup" but this is just a link I found while searching DDG)) https://kb.stonegroup.co.uk/index.php?View=pdf&EntryID=359

If you read this basic document it clearly shows the problem with the uPD720200, uPD720201, and uPD720202 must be solved by modifying the device driver. There is a conflict between the way the hardware recognizes USB 2.0/3.0 devices and the way an operating system performs the same task. This is solved by simply disabling the OS driver's USB 2/3 monitor. The problem I have had, where the device is initialized but fails after plugging in a device is obviously related to the same failure mode mentioned in this PDF. The PDF covers how to fix the issue with Windows and VMware. I do not know if it is possible to fix a problem like this using some kind of virtual machine solution. If it is possible, I need help with this please. If not, how do I go about modifying the driver on my machine(s) or submit this information to get the issue fixed by the Devs? Which Devs? Thanks in advance for any and all help regarding this issue. -Jake

--my system/results from testing/failure w/ mainline kernel and 18.04--

$uname -a
    Linux ********* 5.0.10-050010-generic #201904270832 SMP Sat Apr 27 08:34:43 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

$cat /etc/lsb-release
    DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS"

# dmidecode
    Handle 0x0002, DMI type 2, 8 bytes
    Base Board Information
        Manufacturer: Hewlett-Packard
        Product Name: 30D8
        Version: KBC Version 83.0E
        Serial Number:
        Handle 0x0007, DMI type 9, 13 bytes
    System Slot Information
        Designation: PC CARD-Slot 0
        Type: 32-bit PC Card (PCMCIA)
        Current Usage: Available
        Length: Short
        ID: Adapter 0, Socket 0
        Characteristics:
            5.0 V is provided
            3.3 V is provided
            PC Card-16 is supported
            Cardbus is supported
            PME signal is supported

The card shows up using:

$lspci -nn
    28:00.0 USB controller [0c03]: Renesas Technology Corp. uPD720202 USB 3.0 Host Controller [1912:0015] (rev 02)

However, as soon as any device is plugged in the card fails (tested with both USB powered and self powered external hard drives).

After plugging in any device:

$dmesg | grep xhci
    [11230.209813] xhci_hcd 0000:28:00.0: xHCI Host Controller
    [11230.209822] xhci_hcd 0000:28:00.0: new USB bus registered, assigned bus number 7
    [11230.216144] xhci_hcd 0000:28:00.0: hcc params 0x014051cf hci version 0x100 quirks 0x0000000100000090
    [11230.216519] usb usb7: Manufacturer: Linux 5.0.10-050010-generic xhci-hcd
    [11230.218060] xhci_hcd 0000:28:00.0: xHCI Host Controller
    [11230.218067] xhci_hcd 0000:28:00.0: new USB bus registered, assigned bus number 8
    [11230.218073] xhci_hcd 0000:28:00.0: Host supports USB 3.0  SuperSpeed
    [11230.219102] usb usb8: Manufacturer: Linux 5.0.10-050010-generic xhci-hcd
    [12398.657393] xhci_hcd 0000:28:00.0: remove, state 4
    [12398.662440] xhci_hcd 0000:28:00.0: USB bus 8 deregistered
    [12398.662456] xhci_hcd 0000:28:00.0: xHCI host controller not responding, assume dead
    [12398.662462] xhci_hcd 0000:28:00.0: remove, state 4
    [12398.662690] xhci_hcd 0000:28:00.0: Host halt failed, -19
    [12398.662693] xhci_hcd 0000:28:00.0: Host not accessible, reset failed.
    [12398.662829] xhci_hcd 0000:28:00.0: USB bus 7 deregistered
  • What is your Ubuntu version? How did you installed 5.0.10-050010-generic linux kernel? – N0rbert Apr 30 '19 at 17:57
  • I haven't been able to find the info that guided me through this before, but these are the commands I have in my terminal history: uname -sr sudo apt-get install ukuu sudo ukuu --install-latest uname-sr – jake May 2 '19 at 1:25
  • UKUU installs mainline kernels. Did you have USB3.0 problems with previous and tested/recommended kernels (such as 4.15)? – N0rbert May 2 '19 at 10:01
  • Sorry for the delay N0rbert, and thanks for the replys. Yes, I had the default Kernel v4.15.0-48.51. It had the same issue before I tried the mainline. I tried to use the card with a cheap USB volt/current meter. The voltage doesn't cut out or do anything unusual. I would have to disassemble the laptop to check with a scope. I've been setting up a second old laptop to test the card with shortly. I'm curious if these cheap pcie cards just lack the capacitance needed on the power rails. What else could it be if Linux is recognizing the hardware and initializing it with nothing plugged in? – jake May 4 '19 at 20:48
  • I got 2 similar cards (not sure about shop) and was very disappointed how they work. My cards prevented system shutdown (it rebooted instead just after shutdown). Your case looks as hardware issue too. I think that your laptop operates normally, but expresscards are faulty. I'll consider to buy St-Lab C-510 or something more genuine next time. I would not disassemble laptop in such case. 10$ USB-adapter is <0.1% of laptop cost :) – N0rbert May 4 '19 at 21:06
0

for what it's worth: for mine at least, the power issue mentioned previously seems to be the culprit. I'm running Xubuntu 18.04 LTS (stock kernel) on a Lenovo/ ThinkPad W500 and recently purchased a USB 3.0 adapter (package labeled "Encore Electronics"; "SuperSpeed USB 3.0 ExpressCard ENPUH-302), 34 mm .

The specs on the back of the package state : "Power output:5V /300 mA OR 5V/900 mA with power adapter (not included)".

The device shows up (lsusb): USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)

When inserted, it recognized but could not mount a 5 Gb external USB3.0 drive.

I have one of those USB power adapters (the wire-only kind, with a USB-A male and USB-A female connector, that splits off power to a small hollow power /barrel connector).

Plugging it in resulted in the Express card controller immediately recognizing the external drive . Ubuntu showed it as /dev/sda, and auto-mounted the partitions. Throughput isn't great: 46.3 MB/s to 101 MB/s with a 3 Gb file (and without the drop cache command) , but at least it's way better than the 19.6 Mb/s I was getting with my USB 2.0 port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.