0

This question already has an answer here:

I have installed Ubuntu 18.04 in UEFI mode in laptop pc which has Windows installed in legacy mode. Even though the grub menu appears it doesn't work. Each time I have to press f9 to enter the boot menu and select the UEFI file shimx64.uefi to launch Ubuntu. Is there any way to fix this? Like converting the boot mode to legacy? I tried reinstalling Ubuntu; but it automatically installs in UEFI mode.

marked as duplicate by Scott Stensland, karel, Eric Carvalho, Fabby, Kulfy May 5 at 3:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Yes, it really only is the version of grub. But you first must create a tiny 1 or 2MB unformatted partition with bios_grub flag for grub to install if drive is gpt. If on Windows drive which would have to be MBR, then bios_grub not required. How you boot install media for both Ubuntu & Windows is how it installs & repairs. So boot Ubuntu live installer in BIOS mode. Often easier to use Boot-Repair, but boot live installer in BIOS mode & install Boot-Repair to it. help.ubuntu.com/community/Boot-Repair – oldfred Apr 29 at 19:52
  • How can I boot live installer in bios mode? Each time it automatically boots into UEFI – Saji Francis Apr 29 at 20:41
  • @SajiFrancis you should google : boot Ubuntu live installer in BIOS mode. – Scott Stensland Apr 29 at 20:44

Browse other questions tagged or ask your own question.