0

This question already has an answer here:

Warning:OpenJDK 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0

marked as duplicate by karel, Elder Geek, Eric Carvalho, Byte Commander, Fabby May 3 at 22:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Which version of Java and Eclipse are you using? How you installed that? – Kulfy Apr 29 at 12:27
  • openjdk version "11.0.2" 2019-01-15 OpenJDK Runtime Environment (build 11.0.2+9-Ubuntu-3ubuntu118.04.3) OpenJDK 64-Bit Server VM (build 11.0.2+9-Ubuntu-3ubuntu118.04.3, mixed mode, sharing) – Bhagyashri Ghode Apr 29 at 12:40
  • eclipse java oxygen3 – Bhagyashri Ghode Apr 29 at 12:41
  • 1
    I'm not sure if oxygen is compatible with Java 11. Have you tried proton or newer? – Kulfy Apr 29 at 12:52
  • 1
    How exactly did you install eclipse and how exactly are you trying to run it? Please don't just dump terminal output in your question without any further explanation - make it easy for us to help you by including as much detail as you can. Also please add the version info you replied with in comments to your question too. – Byte Commander Apr 30 at 12:24
1

From Migration Guide JDK 8 to JDK 11 says that in Java 8, Java 9 or Later. the MaxPermSize or PermSize flag has been removed from Hotspot Heap GC Option and was moved to native memory.

Removed Permanent Generation

The permanent generation was removed in JDK 8, and the related VM options cause a warning to be printed. You should remove these options from your scripts:

  • XX:MaxPermSize=size
  • XX:PermSize=size

In JDK 9 and later releases, the JVM displays a warning like this:

Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0

Tools that are aware of the permanent generation may have to be updated.

Or

you can try remove that message using a Environment variable in .bashrc :

MAVEN_OPTS -Xmx512m

Hope this helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.