1

I have gone back and forth through this and other forums trying to find out how to download and install NVIDIA drivers. The answers to previous questions don't appear to help. Either they don't work or things they say are found can't be found.

The driver I want to use is Linux x64 (AMD64/EM64T) Display Driver that I found here.

I have downloaded it and it is in my downloads folder. Now I don't know how to use it.

It doesn't appear in Ubuntu Software -> Add-ons -> Hardware drivers (which I believe used to be called the Software Center).

If I run

sudo apt-get install nvida-Linux-x86_64-340.107

I get

E: Unable to locate package nvida-Linux-x86_64-340.107
E: Couldn't find any package by glob 'nvida-Linux-x86_64-340.107'
E: Couldn't find any package by regex 'nvida-Linux-x86_64-340.107'

If I run:

sudo apt-get install nvida-latest

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nvida-latest

So either how do I point the install to a repository where I can find the drivers, or how do I point it to the file I have in downloads (which incidentally has .run on the end of the name.

I have reinstalled ubuntu several times in the last few days (which in the latest Ubuntu now means I have to use GParted to get rid of the old partitions so they don't interfere with the new).

I think from reading various posts that it isn't necessary to blacklist 'nouveau' which my system is currently using, but I get frequent screen freezes/system hangups which in the past has been down to the video drivers.

Pentium(R) Dual-Core  CPU      E5400  @ 2.70GHz
vendor: Intel Corp.
physical id: 1
bus info: cpu@0
size: 1844MHz
capacity: 2700MHz
width: 64 bits

*-display
description: VGA compatible controller
product: GT216 [GeForce GT 220]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:24 memory:fb000000-fbffffff memory:b0000000-bfffffff memory:ce000000-cfffffff ioport:af00(size=128) memory:c0000-dffff
3
3

Based on experience with driver versions labeled "testing", "edge" and similar, and also using the NVIDIA-provided binaries...

Unless you have a VERY SPECIFIC reason to have the very latest... (often providing new features, or obscure patches and the like that might not even be relevant for your hardware)

The least troublesome choice is:

Ubuntu System Settings> Software and updates> Additional drivers.
(*) Using NVIDIA binary driver ...

e.g. the top two choices here:
Ubuntu System Settings> Software and updates> Additional drivers

1

Hi and welcome to AskUbuntu! The way I found to be the most promising is the following:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo ubuntu-drivers autoinstall

This will install the latest working driver.

4
  • Thanks for the welcome. This ppa appears to be working and I am now off to reboot to see if it works.... – John Haskey Apr 29 '19 at 10:04
  • Good luck and let us know if it worked. – Turtle10000 Apr 29 '19 at 10:06
  • Unfortunateley it appears to have made things worse. I had to go to work and so left the PC with the Ubuntu loadins screen (with the 5 dots) - I had waited longer than normal for it complete the re-boot but had to go out. On return the same screen was showing. I rebooted twice more and each time the boot process stopped at "Started GNOME Display Manager" . I have now booted using the Ubuntu 18.10 start-up disk and indeed the screen showed above by Hannu was there and I changed it from nouveau to Nvidia. Here I go to reboot again - probably won't be persistent though. – John Haskey Apr 29 '19 at 19:53
  • The gui is fine but I had some problems with it (mostly that it failed to set the chosen driver, without notifying me about it). Good luck. – Turtle10000 Apr 29 '19 at 20:11
0

On this page it is suggested that you do this:

apt search nvidia-driver

which will hopefully show some available driver packages. Then you can install one of them for example like this (this works for me):

sudo apt install nvidia-driver-390
1
  • 1
    returns "Package nvidia-driver is not available, but is referred to by another package This may mean that the package is missing, has been obsoleted, or is only available from another source" – John Haskey Apr 29 '19 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.