0

Okay so today I turn on my pc and my monitor is stuck at 640x480, I attempt to change the display settings but it wont let me change any of the options. I tried to switch to a different Nvidia driver (open source and proprietary) to no avail, tried switching back to the Nouveau driver too, still no luck. Not sure what caused this, but I think its happened due to something that updated, I remember when I was last on my pc letting it do some updates. How can I diagnose this and fix it?

Am on Xbuntu Distributor ID: Ubuntu Description: Ubuntu 18.04.2 LTS Release: 18.04 Codename: bionic

  • Edit... I just tried another proprietary driver (version: 4.6.0 NVIDIA 390.116) and it works fine. Testing switching back to open source now... – Z.Davey Apr 28 at 21:46
  • Just tried version: 4.6.0 NVIDIA 430.09 (open source) (which I tried before :S) and it works, not sure what happened, but it must not have installed correctly. switching to the proprietary 390.116, and back seems to have fixed it. – Z.Davey Apr 28 at 21:50
0

This looks like nomodeset.

Make sure that it isn't set somwhere in your ubuntu configuration

grep nomodeset /etc/ -rs

This should print by default only:

GRUB_CMDLINE_LINUX_RECOVERY="$GRUB_CMDLINE_LINUX_RECOVERY nomodeset"

If it appears somwhere else, i.e. in /etc/default/grub - remove it and update grub configuration with

sudo update-grub2

Then reboot.

Also check which graphics driver is in use.

lspci -v

Look for your graphics card or VGA string sections.

In case it's

Kernel driver in use: nouveau

open applications menu and go to Updates -> Settings -> Additional Drivers

or via terminal:

/usr/bin/python3 /usr/bin/software-properties-gtk --open-tab 4

and install one of proprietary drivers available.

Keep in mind that after switching drivers you need to reboot your PC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.