0

So my bluetooth was working fine until last week where a new update came along. I'm guessing this included a kernel update. Then, my bluetooth was disabled and I can't turn it on again.

The service is running but in the switch in gnome-control-center does nothing when hit.

enter image description here

Through lshw I figured out, that I have a RTL8822BE Bluetooth and Wifi device. Wifi is working fine btw.

*-network                 
       Beschreibung: Kabellose Verbindung
       Produkt: RTL8822BE 802.11a/b/g/n/ac WiFi adapter
       Hersteller: Realtek Semiconductor Co., Ltd.
       Physische ID: 0
       Bus-Informationen: pci@0000:03:00.0
       Logischer Name: wlp3s0
       Version: 00
       Seriennummer: 80:2b:f9:bd:d1:8d
       Breite: 64 bits
       Takt: 33MHz
       Fähigkeiten: pm msi pciexpress bus_master cap_list ethernet physical wireless
       Konfiguration: broadcast=yes driver=r8822be driverversion=4.18.0-18-generic firmware=N/A ip=192.168.0.158 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       Ressourcen: irq:143 ioport:d000(Größe=256) memory:df200000-df20ffff

Suspicious about the info firmware=N/A I checked if there are the appropriate firmware files. I read that I should look for rtl8822b_config.bin and rtl8822b_fw.bin under /lib/firmware/rtl_bt/ and they are there.

$ ll /lib/firmware/rtl_bt/rtl8822b*

-rw-r--r-- 1 root root  14 Apr 28 14:58 /lib/firmware/rtl_bt/rtl8822b_config.bin
-rw-r--r-- 1 root root 50K Apr 28 14:59 /lib/firmware/rtl_bt/rtl8822b_fw.bin

Replacing them like suggested in this thread did not help eather. https://askubuntu.com/questions/1003818/rtl8822be-bluetooth-device#=

One last hope that I had was that it was simply blocked. Investigating this I found that this can be seen with rfkill list but no luck there eather ...

$ sudo rfkill list                 
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Here is the output of dmesg | egrep -i 'blue|firm'.

dmesg | egrep -i 'blue|firm'
[    0.028000] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.143301] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    2.153415] usb 1-14: Product: Bluetooth Radio 
[   15.614394] Bluetooth: Core ver 2.22
[   15.614404] Bluetooth: HCI device and connection manager initialized
[   15.614406] Bluetooth: HCI socket layer initialized
[   15.614407] Bluetooth: L2CAP socket layer initialized
[   15.614410] Bluetooth: SCO socket layer initialized
[   15.618901] Bluetooth: hci0: rtl: examining hci_ver=08 hci_rev=627a lmp_ver=08 lmp_subver=b29b
[   15.618902] Bluetooth: hci0: rtl: assuming no firmware upload needed
[   16.046087] r8822be: Using firmware rtlwifi/rtl8822befw.bin
[   20.774984] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   20.774985] Bluetooth: BNEP filters: protocol multicast
[   20.774988] Bluetooth: BNEP socket layer initialized

And dmesg | egrep -i 'r8822be'.

dmesg | egrep -i 'r8822be'  
[   15.884569] r8822be: module is from the staging directory, the quality is unknown, you have been warned.
[   15.885992] r8822be 0000:03:00.0: enabling device (0000 -> 0003)
[   16.046087] r8822be: Using firmware rtlwifi/rtl8822befw.bin
[   16.188308] r8822be: rtlwifi: wireless switch is on
[   16.191197] r8822be 0000:03:00.0 wlp3s0: renamed from wlan0

I realy hope that some one can help me with this issue because it drives me crazy that it was working already but isn't now ...

PS: I also tried to go to a previous kernel but with no luck :/

Update: I also checked that AutoEnable=ture is set in /etc/bluetooth/main.conf.

Thank you all in advance! :)

0

This isn't much of an answer, but I was running into a very similar issue to yours after updating my kernel to 4.18.0-18. When I switched back to 4.18.0-15, Bluetooth seemed to be working again. I ran some diagnostics (lshw, lspci, hdiconfig dev, etc.), but didn't do much else.

When next I switched back to 4.18.0-18, for some unknown reason the issue magically fixed itself. I am unable to reproduce the breakage that I was seeing earlier, which is very spooky but at least it is fixed now.

So maybe, try switching back to an older version of the Kernel and see if Bluetooth comes back? If so then you might be able to figure out what part of the kernel update broke Bluetooth for you, and maybe you'll get lucky like me and the problem will fix itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.