0

I am unable to copy or paste in other local disk in Ubuntu 18.04 LTS.

I have tried sudo chmod -Rf 777 /media/atanu/Study where study is my local disk name. It is showing permission issues.

  • 3
    You forgot to tell us what filesystem you used. Is it ntfs or fat? if so chmod is a -linux- thing not microsoft/windows. chmod 777 is -never- the correct solution. when it is ntfs you set permissions when -mounting-. Please follow the correct procedures when mixing microsoft with linux. – Rinzwind Apr 28 '19 at 13:14
  • 2
    Can you add the output of cat /etc/fstab and ls -la /media/ to your question? – Simon Sudler Apr 28 '19 at 13:32
0

Looks like the destination device has been mounted without write permissions. In such case chmods won't help you much, until your device will have rw flag.

Use mount to check what flag it has while mounted:

sudo mount | grep "/media"

you should see something like this:

/dev/sdaX on /media/atanu type ext4 (ro,relatime)

Just change /dev/sdaX to your device name.

If it's ro this means it's read-only.

Umount the device and try to mount it with rw flag instead:

umount /media/atanu
mount -o rw /dev/sdaX /media/atanu

Pendrive's or SD Cards sometimes has physical switches, that makes them read-only. You may need to switch them be able to write on them.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.