I've got new laptop and I've been trying to install Ubuntu dualboot alongside with Windows 10.

I'm in GRUB menu after boot USB where options are:

  • Try Ubuntu without installing
  • Install Ubuntu
  • OEM install
  • Check disc for defects

Whatever I choose I get a black screen after it.

I tried lot of stuff while I was searching for a solution. In UEFI I set SATA to AHCI, turned off Secure Boot and Fast Boot.

I tried edit the command from GRUB replacing quiet splash with nomodeset, nvidia.modeset=0 or nouveau.modeset=0. Nothing helped.

I used Ubuntu on my old laptop and everything works just fine. I also tried to boot from the USB drive from another PC and it works. So there is no problem in the USB media.

I've got new Asus ZenBook Pro 14 UX480

  • CPU Intel Core i7 8565U Whiskey Lake
  • GPU Nvidia GeForce GTX 1050 Max-Q

Thanks for any advice!

  • Make sure you're booting in UEFI mode then add nomodeset. This is all you need to run a live session (and install) with a generic video mode. Later you need to boot with the same parameter and install Nvidia drivers. This assumes the media you're booting is working fine. – user880592 Apr 29 '19 at 12:55
  • What version of Ubuntu? If it's an issue with ACPI tables you might just need a newer kernel? This user says 18.10 worked for them: reddit.com/r/linuxhardware/comments/a3ddg6/… – nyov Aug 27 '19 at 4:51
  • It could also help to know if it has hybrid graphics (integrated intel gpu as well as that nvidia); and if so, see if you can disable one or the other in the BIOS. – nyov Aug 27 '19 at 5:03

TL;DR - Add "acpi=off" to kernel command line.

The nomodeset option is used for a "safe graphics" install, but maybe your issue isn't related to graphics.

In the past, I have had success in this situation by trial and error with the following:

  • modify kernel cmdline settings, press 'e' at the GRUB menu, and replace "quiet splash" (as you have done) with "noacpi acpi=off".
  • update BIOS/UEFI firmware.
  • change various BIOS settings related to power management and other devices.
  • disable eveything in the BIOS that is not required.
  • change various settings related to security/hard drive
  • plug in an external monitor.
  • try a different flash drive, even though you mention that the drive works fine on a different PC.
  • Try a newer version of Ubuntu - I'm assuming that you're using 18.04 - 19.04 is awesome too.
  • use a usb-serial adaptor to output console to a serial console.

Ubuntu 18.04.3 LTS uses kernel version 5.0, so you can find the full list of kernel cmdline parameters here (search for X86, or options that start with 'no' or 'dis'):

From above link, other options that might help: nosmep nosmap nosmt nolapic nopcid noapic nolapic nomodeset dis_ucode_ldr pci=nobios pci=noacpi

If you are successful, please post what works for you. Booting on the latest hardware has always been a battle with Linux because manufacturers are balls. At least you usually don't have to compile your own kernel these days.

  • I tried the suggested boot command options with Ubuntu 19.04 - they work! Thanks for your list of possible pitfalls. Before I saw your answer I stumbled upon another thread in an ASUS board where acpi=off was suggested. This works as well. – pixelbrackets Aug 28 '19 at 19:25
  • Thanks @pixelbrackets, I have updated the post. According to the docs, it looks like noacpi might not be useful on ARM, and noacpi is now deprecated in favour of acpi=off. – ThankYee Aug 30 '19 at 10:00
  • You can debug what exactly doesn't work with the info provided here – Aistis Mar 25 at 10:40

I had the same problem with my brand new Zenbook.

The above trick did not help, but with adding nouveau.modset=0 to the end of the line instead of acpi=off and leaving quiet splash in place, I managed to get Ubuntu 19.04 to launch.


I have Asus Vivobook and have same problem. This method are works: press 'c' to coomand-line , type 'set gfxmode=1024,768' type 'normal' and hit Enter to back to menu press 'e' to edit boot parameters type this parameter after kernel name (before other parameters) 'nvidia.modeset=0' then press F10 too boot.

I Love Linux :-* Mehran Yoosefi


I have the same model »Asus ZenBook Pro 14 UX480« and the same issue. I was able to overcome to black screen and start the live mode with the following steps:

  1. Open Windows to allow disabling »Secure Boot« and browse to Settings > Update & Security > Advanced Startup options > Restart Now (will then open BIOS/UEFI automatically)
  2. In BIOS/UEFI disable »Secure Boot« & disable »Fast Boot«
  3. Save and exit
  4. Shut down, insert USB-Stick with bootable Ubuntu 19.04 (I tried Ubuntu 16.04, Ubuntu 18.04 and Mint 18.04 without any success)
  5. Hold F2 and press the power key to enter BIOS/UEFI
  6. Select the USB-Stick as Boot Option or Boot Override
  7. When the linux boot options appear select Try Ubuntu without installing (safe graphics) using the arrow keys quickly and hit e to modify the start command
  8. Replace quiet with acpi=off (source) or use the options suggested by @ThankYee
  9. The live mode appears

To install Ubuntu then it is neccessary to:

  1. Switch from the pre-installed RAID drivers (Intel Rapid Storage Technology) to AHCI drivers BIOS - otherwise the live mode wont detect the SSD

Update 2019-09-29

I was not able to install Ubuntu alongside with Windows 10 - The installation always ended with an GRUB error. I was able to install Ubuntu as single OS however. I was able to install Ubuntu with LUKS/LVM encryption as well, but it required a manual update of GRUB after the installation using »boot repair«.

These problems still persist:

  • The second screen underneath the touchpad is not working
  • The touchpad is not working
  • The buttons to adjust the screen brightness are not working
  • Because of the acpi=off hack the battery status is not available
  • Because of the acpi=off hack hibernation is not available
  • It is not possible to install the Nvidia drivers - even with manual upgrades to the latest kernel

Update 2019-10-17

Today Ubuntu 19.10 was released and it works almost perfectly. 💜

To start the live mode, do everything above, but replace quiet splash with nomodeset (no need for the acpi hack anymore).

The installation now works just fine. No Grub errors, no need for »boot repair« fixes with or without encryption. Ubuntu 19.10 even installs all needed Nvidia drivers automatically now.

The problems described above are gone, except for the second screen underneath the touchpad. The touchpad is working, brightness is working, battery icon, Nvidia drivers etc.

Update 2019-10-23

Two bugs reappear on a regular basis:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.