3

So in Minecraft, the section sign (§) can be useful to make colors in text and so on. However, I can't seem to type it. I've tried pasting the character in using Ctrl-V as well as middle mouse. I've even tried using xdotool type "§", but it just doesn't register, even though using xdotool type "foobar" will work. Is Minecraft perhaps just filtering out that character or something on Linux?

Update: I found out that the Minecraft client doesn't accept the § symbol for generating color/style sequences in text. The use of those sequences is for the server only. However, I did find out that in recent versions that if you want to change the color of text on a sign, you just apply dye to it, which is what I wanted to use the sequences for anyways.

5

to type special characters in the terminal you need to use the compose key

To configure the compose key on Ubuntu, you need to install dconf and you can find the setting in the package dconf/org/gnome/desktop/input-source/xkboptions

From Ubuntu 14.04

dconf → org → gnome → desktop → input-sources → xkboptions

e.g. to set the Alt Gr key as compose:

['compose:ralt']

Then you can use the compose key to type that special character.

By pressing Compose, some key, some key… in sequence, you can input characters. I have my compose key set to Menu; to type a © (copyright symbol), I would use Menu, o, c.

A full list of X compose key combinations can be found online (200 KiB), or locally in /usr/share/X11/locale/en_US.UTF-8/Compose.

The character "§" is included in the below list

XCOMM Other symbols
<Multi_key> <s> <o>                 : "§"   section # SECTION SIGN
<Multi_key> <o> <s>                 : "§"   section # SECTION SIGN
<Multi_key> <S> <O>             : "§"   section # SECTION SIGN
<Multi_key> <O> <S>             : "§"   section # SECTION SIGN
<Multi_key> <s> <exclam>        : "§"   section # SECTION SIGN
<Multi_key> <S> <exclam>        : "§"   section # SECTION SIGN
<Multi_key> <Cyrillic_pe> <Cyrillic_a>  : "§"   section # SECTION SIGN

The other option is typing the Unicode character as suggested from Sergiy Kolodyazhnyy.

The unicode character is available in this table

  • Thanks, this is a useful answer, it turns out that the Minecraft client just doesn't accept that symbol intentionally. – deltaray Apr 28 '19 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.