0

I know that this is a noob question, but i need to be able to manually install the Ethernet driver on my Dell Poweredge R610 because it doesn't install any drivers by default to connect to the internet. Any help on being able to do this would be appreciated.

Result from command lspci -nnk | grep 0200 -A3 Note: Since i have no SSH or internet, LAN or WAN. I had to type this out manually, their may be errors.

01:00.0 Ethernet controller [0200]: Broadcom Inc. and subsidiaries NetXtreme II BCM5709 Gigabit Ethernet [14e4:1639] (rev 20)
    Subsystem: Dell PowerEdge R610 BCM5709 Gigabit Ethernet [1028:0236]
    Kernel driver in use: bnx2
    Kernel modules: bnx2
01:00.1 Ethernet controller [0200]: Broadcom Inc. and subsidiaries NetXtreme II BCM5709 Gigabit Ethernet [14e4:1639] (rev 20)
    Subsystem: Dell PowerEdge R610 BCM5709 Gigabit Ethernet [1028:0236]
    Kernel driver in use: bnx2
    Kernel modules: bnx2
02:00.0 Ethernet controller [0200]: Broadcom Inc. and subsidiaries NetXtreme II BCM5709 Gigabit Ethernet [14e4:1639] (rev 20)
    Subsystem: Dell PowerEdge R610 BCM5709 Gigabit Ethernet [1028:0236]
    Kernel driver in use: bnx2
    Kernel modules: bnx2
02:00.1 Ethernet controller [0200]: Broadcom Inc. and subsidiaries NetXtreme II BCM5709 Gigabit Ethernet [14e4:1639] (rev 20)
    Subsystem: Dell PowerEdge R610 BCM5709 Gigabit Ethernet [1028:0236]
    Kernel driver in use: bnx2
    Kernel modules: bnx2

cat /etc/netplan/*.yaml

# This file is generated from information provided by
# the datasource. Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
network:
    ethernets: {}
    version: 2
  • Would you mind if a non-noob checked your work? Let's see what device you have and the probably drivers. Please run the command: lspci -nnk | grep 0200 -A3 Next, edit your question to add the result. Welcome to Ask Ubuntu. – chili555 Apr 26 '19 at 21:58
  • @chili555 Done, thanks for helping. – Simulink Apr 26 '19 at 22:36
  • It appears that all four of your ethernet interfaces have a suitable driver, namely bnx2. Does your server not connect to the internet? What have you done to try to fix it? May we see: cat /etc/netplan/*.yaml – chili555 Apr 27 '19 at 13:11
  • @chili555 No, my server is not able to connect to the internet, i tried enabling dhcpcd, didn't help, cat /etc/netplan/*.yaml output edited in. – Simulink Apr 27 '19 at 15:38
  • May we also see: sudo dhclient -v The output will be lengthy but there will be one (of the four) interface that attempts to connect, presumably the one connected to the router or switch by an ethernet cable. You may omit the unsuccessful attempts but show us the result of the obviously attempted to be connected interface. We'd like to know the relevant interface, enp3s0 or eno2 or some such. I will then propose a working solution. – chili555 Apr 27 '19 at 20:11
2

Your netplan file currently says:

# This file is generated from information provided by
# the datasource. Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}

I suggest that you do exactly that. From the terminal:

sudo -i
echo "network: {config: disabled}"  >>  /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg

Next, let's amend the netplan file to add your configuration:

nano /etc/netplan/50-cloud-init.yaml

Edit the file to read as I suggest below to include your settings:

# This file is generated from information provided by
# the datasource. Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
network:
  version: 2
  renderer: networkd
  ethernets:
    eno1:
      dhcp4: true

Netplan is very specific about indentation and spacing. Please proofread carefully twice. Save (Ctrl+o followed by Enter) and exit (Ctrl+x) the text editor. Next:

netplan generate
netplan apply
exit

Reboot. You should be all set.

EDIT: If you prefer a statis IP address which is recommended for servers, I suggest that your /etc/netplan/50-cloud-init.yaml file be amended to:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp3s0:
      addresses:
        - 10.10.10.2/24
      gateway4: 10.10.10.1
      nameservers:
          addresses: [10.10.10.1, 8.8.8.8]

Of course, substitute your details here. Follow with:

sudo netplan generate
sudo netplan apply

Reboot.

REFERENCE: Please see the many netplan templates at /usr/share/doc/netplan/examples.

| improve this answer | |
0

It looks like you have proper firmware already. Make sure that you are actualy connected to the Internet on your NIC. If you have physical access to the server just plug its ethernet cable to anoher device and check if it works.

Lastly, we don't know what is your network configuration, maybe there's no DHCP running and you need to set up your network configuration manualy on one of four interfaces. It includes interface configuration, such as IP, gateway, netmask, broadcast, routes and DNS servers.

Off-topic note: If you're prompted for missing firmware during ubuntu installation you should write down which devices lacks of firmware packages. Then you can download them separately as .deb packages, write them f.e. on pendrive and point their location during installation.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.