2

On an old laptop with Lubuntu 18.04, I have sisfb working properly. It's not blacklisted at all and loads on boot.

The problem is that sisfb is normally blacklisted in /lib/modprobe.d/fbdev-blacklist.conf. While I can comment that line out, whenever the udev package is updated using the weekly GUI update reminder, /lib/modprobe.d/fbdev-blacklist.conf is overwritten. While I can use chattr +i /lib/modprobe.d/fbdev-blacklist.conf to block the update from overwriting the file, that causes udev updates to fail, which causes apt full-upgrade to fail. Since the laptop is for the use of someone new to computers, this isn't a workable method.

How can I load sisfb properly during boot?

2

You can workaround this by creating simple bash script and running it via cron or add it as systemd unit.

#!/bin/bash

SLEEP_TIME=30 # how often do the checks
BL="/lib/modprobe.d/fbdev-blacklist.conf"

while [ true ]; do

    SISFB_BL=`grep "blacklist sisfb" $BL`

    if [[ "$SISFB_BL" ]]; then

        # sisfb un-blacklist
        sed -i '/blacklist sisfb/d' /lib/modprobe.d/fbdev-blacklist.conf

    else

        echo "[ ok ] sisfb blacklist not found"

    fi

    sleep $SLEEP_TIME

done

save it i.e. as /opt/sisfb_blacklist_watcher.sh

and add to cron on root:

sudo -i
crontab -e
@reboot /opt/sisfb_blacklist_watcher.sh &> /dev/null &
2
+200

From ServerFault:

This answer:

apt-get install -o Dpkg::Options::="--force-confold" --force-yes -y udev

Read the comments below the answer though. It suggests --force-yes is sometimes an extreme option although it's not explained clearly.


An even better ServerFault answer is found here:

This Answer:

You can pass options to dpkg from apt. Interesting for you would be the option --force-confold. The command looks like this:

apt-get -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" upgrade

Setting --force-confdef as well makes apt-get still update the config file if it hasn't been edited, while --force-confold will keep edited configuration files without asking.

To make this permanent, you can also set these options in your apt.conf file:

Dpkg::Options {
   "--force-confdef";
   "--force-confold";
}

Check e.g. http://debian-handbook.info/browse/wheezy/sect.package-meta-information.html#sidebar.questions-conffiles

  • Unfortunately, the udev package inscrutably doesn't consider that to be a configuration file (dpkg --status udev). I'll file a bug for that. – Chai T. Rex May 5 at 1:51
  • 1
    You would think anything ending in .conf should be respected as a configuration file and the industry standard rules should be followed. Perhaps a hook into shutdown / reboot scripts can run diff on current .conf file and saved copy. If different clobber the current file with saved good copy? – WinEunuuchs2Unix May 5 at 1:55
  • I've submitted a bug report. That's not a bad idea. I'll look into shutdown scripts for now and then use this answer if and when the bug is fixed. Thanks for your suggestions. – Chai T. Rex May 5 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.