3

I want my notebook (Lenovo-U31-70) to be able hibernate/suspend and i can't do that. I think that i test all the basic solutions I find and nothing works... I need help to understand what it can be.

I test all the ubuntu versions (16.10 - 19.04) and nothing works. I hate to use windows but i need to use because of the hibernate function that windows has working.

I have dual-boot win10/ubuntu 19.04 with a 8GB ram and a swap with 11GB

So on this last 3 versions I have done the following. manually test the option.

$ sudo systemctl hibernate

and of course doesn't work, the display gets black and the power button on, but some times restarts it self. So need pass to the configurations.

$ cat /etc/fstab
$ sudo gedit /etc/default/grub
$ GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=/dev/sda7"
$ sudo update-grub
$ sudo reboot

After the above changes the result has some changes but not what i want. The hibernation starts and our notebook shutdown our stays with the display black again.

When the shutdown ocours the restart doesn't resume but starts a new session.

I don't now what i can test more.

I have test other linux distros the Fedora and the hibernation occours without any configuration, but the resume it's the same starts a new one.

3
  • Hibernation isn't enabled by default - perhaps for a reason? - but suspension is and works fine in all systems I've tested. – user880592 Apr 26 '19 at 11:38
  • 1
    suspend works on ubuntu 18.10. On 19.04 it also works but has a tendency to be stopped by incoming network traffic which is annoying. – tatsu Apr 26 '19 at 11:39
  • Yes, the hibeernation comes disable, but why in Fedora some times works? – Mr_mufy Apr 26 '19 at 22:28
2

For my Ubuntu 19.10 (eoan) hibernate package from universe works seamlessly, when pm-utils fails.

Hardware: Dell Precision 7510

sudo apt-get install hibernate
sudo hibernate

NOTE: don't forget to save all your open documents before trying to hibernate for the first time.

1

NOTE: If you are using an encrypted swap partition, then please follow these instructions on the Ubuntu help site.

I hope this will help someone, but I'm running Pop! OS / Ubuntu 19.04 (update also works for 19.10 release). In my setup I was able to hibernate using s2disk or pm-hibernate, but resume was failing. To fix this, as my system is booted up using UEFI instead of GRUB, I just had to reinstall the boot loader. To check if you are running UEFI use the following:

[ -d /sys/firmware/efi ] && echo "Installed in UEFI mode" || echo "Installed in Legacy mode"

if in UEFI mode, then I followed this guide to reinstall the bootloader, it varies if you are using an nvme disk or sata disk: https://support.system76.com/articles/bootloader/

The key is to run this command:

sudo update-initramfs -c -k all

make sure that in your kernel boot options you specify the partition or UUID of where to resume from, eg something like this:

resume=UUID=ed8347ed-2eb4-40bc-bc77-cc53b987ed88

You can add this by either:

  1. Running the command sudo kernelstub -a "resume=UUID=ed8347ed-2eb4-40bc-bc77-cc53b987ed88"
  2. Editing the /etc/initramfs-tools/conf.d/resume file and adding: resume=UUID=ed8347ed-2eb4-40bc-bc77-cc53b987ed88

check your /var/log/syslog file for something like this:

Aug  4 22:26:42 pop-os /usr/bin/kernelstub[19639]: kernelstub           : DEBUG    kopts: root=UUID=b37019a8-91f5-445f-94c1-7359a49ed5df ro quiet loglevel=0 systemd.show_status=false resume=UUID=ed8347ed-2eb4-40bc-bc77-cc53b987ed88

If the resume is missing or wrong then you'll need to update your boot kernel again.

1
  • Thanks for this - got me most of the way there. A couple of notes: I tried adding /etc/initramfs-tools/conf.d/resume first, but this didn't do anything for me. Have submitted an edit for the kernelstub command as the added '-' threw me at first. Also possibly worth noting that that hibernate via systemctl worked, rather than pm-hibernate I was using at first. – lambfrier Jan 10 '20 at 23:36
0

Simply just click the search or windows button and type sleep, you should see a pause icon. Click that and your computer is gonna go into hibernation

1
  • This will suspend, not hibernate. – koyakun Mar 10 '20 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.