0

I have a Lubuntu installed on my vmware it was run perfectly untill I updated it then I started to get the lxde xsession problem and I lost the gui but I can read my files from command line and I lost the access to the internet so i can't installing lxde gui using command line so what I do ? to get the internet back i tried sudo ifconfig <logical name> up the command worked but the internet connection still lost

  • You haven't given us much to work with. What release of Lubuntu? Do you, or can you assign a static ip address? can you ping your closest switch? or say google's dns (ie. ping 8.8.8.8 without using DNS, or do you get issues only if you if try & use DNS, ie. ping dns.google.com) etc – guiverc Apr 26 at 1:24
  • @guiverc i get network unreachable with ping 8.8.8.8 and name or service not known with ping dns.google.com and i have ubuntu 18 – shar Apr 26 at 7:58
  • There is no Ubuntu 18, so do you mean Ubuntu Core 18? (an IoT intended version of Ubuntu which is yy in format) or something else. Most standard desktop/server editions of Ubuntu are yy.mm in format (having multiple releases per year), and only special purpose releases are yy in format (like Ubuntu Core 18) having only a single release per year. – guiverc Apr 26 at 11:36
0

this command fixed the internet disconnection problem for me sudo dhclient <logical name>

for me my logical name was ens33 sudo dhclient ens33

that's how to know you logical name use this command sudo lshw -class network

then to fix you internet connection

sudo dhclient <logical name>

then I used this command to install the gui to fix the xsession and lxde gui problem

sudo apt-get install lxde

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.