0

So after updating to 19.04, I got some problems concerning some packages, especially udev. I guess it was a mistake, but I removed and re-installed udev. After that everything worked fine and I got no errors. Next time I try to boot into ubuntu (I have dual boot, but I don't think that's the problem) I got no GUI, only a terminal. I have tried reinstalling ubuntu-desktop as I saw in other posts, but that didn't work because the internet doesn't work, even with an internet cable. Do you have any suggestions?

  • When I once lost GUI (probably due to upgrading python to unsupported version) I was able to connect to my home wifi using one of the answers sugested in this post Sadly, I dont remember which one exactly but it did not include nmcli nor nmtui. I only have this link bookmarked under name **SOLUTION***. ( And as for your main problem I wasn't able to restored my GUI due to bunch of commands I used trying to get old python version) – BanAnanas Apr 25 '19 at 19:24
  • Unfortunately I have already some of these and I couldn't connect with wifi. – John Fikioris Apr 25 '19 at 19:28
  • Do you have wpa_supplicant? I think that was the one that worked in my case. And maybe find out if you need to change wlan0 in commands to sth. else if you haven't already. I don't think I know how to help beyond that. Good luck! – BanAnanas Apr 25 '19 at 19:36
  • What do you mean if I have wpa_supplicant? – John Fikioris Apr 25 '19 at 20:30
  • You could boot from installation USB if you still have it, bind couple directrories via chroot and install that way. help.ubuntu.com/community/LiveCdRecovery – Sergiy Kolodyazhnyy Apr 25 '19 at 23:11
0

Try running startx. This is the command to start the GUI. It will give you a log in Xorg's log file if it fails. Post that content for troubleshooting.

  • It failed. The error essage was xauth: timeout in locking authority file /home/John/. Xauthority xauth: timeout in locking authority file /home/John/. Xauthority /etc/X11/xinit/xserverrc: 3: exec: /usr/bin/X: not found xinit: giving up xinit: unable to connect to X server: Connection refused xinit: server error xauth: timeout in locking authority file /home/John/. Xauthority – John Fikioris Apr 25 '19 at 20:42
0

I don't know if this can be considered as an answer, but unfortunately I reinstalled Ubuntu. Also I'd like to point out for the future BanAnanas's comment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.