0

I've searched many times but I was not able to find any solution, so that is why I am asking here: I am suing Lenovo T480 with Lenovo Docking Pro station which is actually Thunderbolt docking station. However, after doing all suggested setting over the internet for the thunderbolt, I am ablt to use only USB 3.0 devices on the docking station USB ports. The station has 3 USB 3.0 and 2 USB 2.0 ports, but on all of them USB 2.0 devices are not recognized by my Ubuntu 19.04 with kernel 5.0.0-13 However - for example on the USB 3.0 ports - flash drive with USB 3 support works fine, but my keyboard and mouse are not.

dmesg is reporting: [ 6.162196] usb usb3-port1: Cannot enable. Maybe the USB cable is bad? [ 6.162232] usb usb3-port1: unable to enumerate USB device

In my /etc/default/grub I have added: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi=force iommu=soft"

and in my BIOS I've changed the Thunderbolt Assist to Enabled and Thunderbolt Security to No Security. Also updated the bios and the docking firmware to the latest versions from Lenovo support website. Still no change. I guess it is something with the linux kernel itself, that does not recognize the USB 2.0 devices there as they are actully trying to pass (at least some error is appearing) I was having such issue long time ago with an Gigabyte desktop motherboard for socked AM3+ and there I had to disable the hardware IOMMU and enable the soft IOMMU in the kernel, but this is not helping here.

Please, give me some advice as this is really frustrating! Thanks!

0

Reset the usb system for the usb port on the dock:

echo -n "0000:3c:00.0" | sudo tee /sys/bus/pci/drivers/xhci_hcd/unbind; sleep 2 && \
echo -n "0000:3c:00.0" | sudo tee /sys/bus/pci/drivers/xhci_hcd/bind

Somehow the issue solved itself in my case after months of irritation -- probably a kernel fix.

0

I've actually managed to fix this by doing this:

  1. Upgrade the BIOS to the latest version
  2. Upgrade the docking station firmware to the latest version
  3. Upgrade the Intel Integrated ThunderBolt 3 Controller Firmware to the latest version
  4. Upgrade the kernel to the latest version / reinstall / recompile it
  5. Turn ON ThunderBolt Assisted Mode in the BIOS

Now everything works as it should.

-1

I have the same issue. these docking stations are garbage. Creating lots of extra work at my company. the docking station firmware update makes it worse. Lenovo needs to get their act together and fix this. I have found putting the computer to sleep and putting back on the dock sometimes helps. i also found running the lenovo system update until the external stuff starts working then quit out before it actually does anything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.