I have a dual boot (windows 10 and Ubuntu 18.04) laptop. I wan to keep a separate partition common to both operating systems.

I formatted that partition as NTFS form windows, Then I could only read it from Ubuntu. I could not write on it. Then I formatted it Using Ubuntu. After that I could read and write using Ubuntu. Later, I saved some file on it using windows. Then after I got the same problem. Now I cant write on it using Ubuntu.

I reinstalled ntfs-3g, but could not solve the problem. What can I do to solve it?

  • 3
    If you search AskUbuntu for "ntfs read only" there are quite a few entries about this problem. Many of them suggest that the disk is considered 'dirty' and the fix is to tun chkdsk in Windows. Another common problem is that Windows fastboot is still enabled (which will result in 'dirty' disks). The Linux implementation of NTFS is not superb and fixing problems with ntfs disks, and Windows utilities should be used if possible. – Charles Green Apr 25 '19 at 13:47

your windows is putting the "read-only" flag on all detectable ntfs partitions everytime it shuts down or reboots.

If you don't want it to do that, boot to your windows, open up a administator powershell (to do that find powershell in start, right click on it, then select "run as Administrator").

then type :

powercfg -h off
  • 4
    Disabling hibernation solved the problem. – Duli Apr 25 '19 at 19:02
  • 1
    hibernation on windows is still possible after that BTW. this only makes "hyper boot" impossible on windows. – tatsu Apr 26 '19 at 7:10
  • if you don't want to use the command as @tatsu mentioned, you can turn off the fast startup mode by using the Power Options in Control Panel. – Quinn Wynn Apr 1 '20 at 1:25
  • @tatsu Can you tell me please how is hibernation still possible on Windows? Because the option isn't in the power menu anymore, and it's not available in the power settings as before running this command. – Ameer Taweel Jul 28 '20 at 10:05
  • well do you really need that? you can sleep the computer instead of hibernating it. in any case if you ubuntu install completed successfully you can re-enable it with powercfg -h on or with a windows update (you'll also need to reboot in both cases). – tatsu Jul 29 '20 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.