4

I am the owner of a HP EliteBook 840 G1 and the "mic mute" button light on the F8 key is always on.

I have tried to turn it off by enabling the boot options CONFIG_SND_JACK, CONFIG_SND_HDA_INPUT_JACK, CONFIG_SND_HDA_CODEC_SIGMATEL (as mentioned here), but to no avail.

2 Answers 2

3

The solution is:

create a local .hwdb file with correct mapping in /etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb:

# see also: /lib/udev/hwdb.d/60-keyboard.hwdb
evdev:atkbd:dmi:bvn*:bvr*:bd*:svnHewlett-Packard*:pn*EliteBook*:pvr*
KEYBOARD_KEY_81=f20                          # Fn+F8 on Elitebook, map to F20
# KEYBOARD_KEY_81=fn_esc                      # org entry

then generate a new /lib/udev/hwdb.bin file and reload it:

sudo udevadm -d hwdb --update; sudo udevadm -d control --reload; sudo udevadm trigger

Credit goes to the source here.

3
  • I have the same problem. Could you explain this in more detail. How do you "create a local .hwdb file with correct mapping in" and " generate a new /lib/udev/hwdb.bin file and reload it"
    – Vaolter
    Apr 20, 2020 at 18:36
  • @Vaolter 1. You create a file with your editor of choice (gedit, vim, emacs...) and you write to it the content above.
    – bela83
    Sep 2, 2020 at 7:01
  • 2. You generate a new hwdb.bin file by opening a terminal emulator and typing in the given command.
    – bela83
    Sep 2, 2020 at 7:01
1

I got the mic mute button to enable/disable the mic, and show the on screen on/off pop up.

Note the light will only go on or off when the pulse audio input control is set to use the built in mic, not any other mic. Then you can enable / disable from the button and have the light turn off.

Instructions are here: https://wiki.archlinux.org/index.php/HP_EliteBook_840_G1#Enable_the_microphone_muting_key

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.