This is an annoyance, but I thought I should post about it and see if anyone knows the solution.

I found:

But my situation is different as the laptop DOES eventually log in, it just takes a while (like 10 seconds or so, even if the user was already logged in and just locked).

I did try disabling Wayland, and it did not affect the problem (i.e. nothing improved).

I also found:

But there are no answers; it's probably related since I've had to log in a second time at least once.

The usual case is that I will come to the laptop (which is a family laptop which rarely has fewer than three users logged in), swipe up and find the lock screen for another user, click "log in as another user", wait for a second or two while it switches to the main login window, click on my name, type in my password, press enter, and then watch the screen blink nine times between a black screen and the login window (where I just put in my password) before it logs me in.

This isn't just my account; all the users in the family have this experience.

The question: How can I make logins faster and get rid of the flashing black screen experience?

(I'm expecting more information will be needed to answer the question, but I'm not sure what information I should include.)

The hardware is a Lenovo ThinkPad L540.

  • I’ve switched to lightdm as this appears to be a bug in gdm. Hopefully it will be fixed when 20.04 rolls around.
    – Wildcard
    May 25, 2019 at 22:01
  • Nope, lightdm still has the issue. However, it doesn’t freeze up when I exit a virtual terminal the way gdm does.
    – Wildcard
    Jul 13, 2019 at 9:39
  • something in journal? journalctl | egrep 'gnome-shell|gdm|input|lightdm'
    – nobody
    Sep 30, 2019 at 9:59
  • @nobody that produces thousands and thousands of lines of output. I'll try looking at the recent errors next time I see the issue, but any more specific filter could be helpful.
    – Wildcard
    Oct 1, 2019 at 6:04

1 Answer 1


I got same problem and tried to fix it for some time.

Try this one, this worked for me:

gsettings set org.gnome.shell.extensions.dash-to-dock transparency-mode FIXED

I found this solution here: https://ubuntuforums.org/showthread.php?t=2404491

Another user reported success by removing ubuntu dock extension

sudo apt-get remove gnome-shell-extension-ubuntu-dock

( I didn't tried this one jet, waiting for results after transperency-mode change )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.