2

After I put my computer to sleep, my bluetooth didn't work.

I reinstalled bluez following the instructions in this post but it didn't work.

rfkill list gives me:

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

I'm on Ubuntu 19.04.

enter image description here

UPDATE

When I run

dmesg | grep -i blue

I have no output. Seems like my bluetooth adapter is not detected. That's strange because it was working well before...

I booted Ubuntu from a USB stick and bluetooth was disabled too.

UPDATE 2

I updated my BIOS thinking it would re-detect / activate the bluetooth adapter but it did not solve my problem.

  • Have you tried to restart the computer? Also restart the devices and make the device discoverable – saitam Apr 25 '19 at 23:02
  • @saitam Yes I restarted my computer many times. My devices are discoverable, but since I cannot enable bluetooth in my Settings, it's normal I cannot see my mouse or keyboard. – alord04 Apr 25 '19 at 23:26
  • Have you tried instead of restarting it to power it off and on again? (this worked once for me when I had bluetooth issues) Also have you tried to set bluetooth in your BIOS off and on? – saitam Apr 25 '19 at 23:36
  • Does sudo systemctl restart bluetooth do anything? – John Mee Jun 3 '19 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.