When I click on links in some applications it can take up to a minute until the open in the browser. This is regardless if the default browser is chrome or firefox.

Example applications where opening links is normally fast:

  • within the browser
  • Konsole (default terminal window)
  • franz (installed as snap application)
  • tusk (installed as snap application)

Example applications where opening links take up to a minute until a new tab is opened in the browser:

  • rider (installed as snap application)
  • slack (installed as snap application)
  • VS Code (installed as snap application)

This started after I upgraded today to Kubuntu 19.04 from Kubuntu 18.10

VS Code, Slack, Franz AND Tusk are all based on electron, it seems weird that one would behave differently from the other, but that's what I see.

Is this a known issue? How can I fix it? How can I figure out where that time is lost?


Even running xdg-open https://askubuntu.com/questions/ask inside the terminal in rider, it was stuck for a long time:

> $ time xdg-open https://askubuntu.com/questions/ask
xdg-open https://askubuntu.com/questions/ask  0,12s user 0,07s system 0% cpu 2:05,35 total

however, running xdg-open from konsole works fast and both of them seem to be pointing to the same application, running it from a terminal within VSCode showed some errors, I resolved them and afterwards it was quick, but clicking on link in VSCode was still slow.

I'm not sure how to look for the root cause for this.

Update 2:

I also installed sudo apt-get install ttf-mscorefonts-installer around the same time I upgraded kubuntu from 18.10 to 19.04 - I can't imagine that having anything to do with it, but if nobody else has this issue

  • Have you tried turning off Tracker (search engine) file indexing? Apr 26 '19 at 11:04
  • @WinEunuuchs2Unix it's on kubuntu. tracker doesn't seem to be running: > $ sudo ps aux | grep -i tracker MY_USER 27183 0.0 0.0 9348 972 pts/0 S+ 16:17 0:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn -i tracker
    – peter
    Apr 26 '19 at 14:19
  • I had exactly the same issue. The font-configuration mentioned in the accepted answer did the trick for me.
    – scravy
    Sep 11 '19 at 8:42

I was having the same issue until I found a solution. Whenever I tried to click a link in Slack, the logs in journalctl -f showed:

xdg-desktop-portal-kde[1886]: xdp-kde-settings: Read called with parameters:
xdg-desktop-portal-kde[1886]: xdp-kde-settings:     group:  "org.kde.kdeglobals.General"
xdg-desktop-portal-kde[1886]: xdp-kde-settings:     key:  "menuFont"
xdg-desktop-portal-kde[1886]: xdp-kde-settings: Key  "menuFont"  doesn't exist"

It turns out I was missing some values in my .config/kdeglobals configuration file, as the error above shows. You can regenerate the missing values by going to System Configuration -> Fonts -> Do any random change -> Apply.

After doing this the links started working fine.

  • 3
    YES that was it, thank you very much
    – peter
    May 15 '19 at 9:15
  • 1
    I had exactly the same issue, this did the trick for me.
    – scravy
    Sep 11 '19 at 8:42

When opened with affected apps (i.e. Slack) it hangs on "kde-open5 https://some-url" (which is launched by xdg-open).

I've tried to debug this with strace:

mv /usr/bin/kde-open5 /usr/bin/kde-open5.orig

Then created an executable (chmod 755) /usr/bin/kde-open5 with the following content:


strace -f -s 1000 -tt /usr/bin/kde-open5.orig $@ &>/tmp/kde-open5-$RANDOM.log

And seeing where exactly it hangs.

I think it deserves its own Launchpad ticket?

  • 1
    Out of curiosity, what was the method you used to discern that xdg-open in the affected apps calls kde-open5?
    – Andrew
    Apr 26 '19 at 0:57
  • thx, could it be related to bugs.launchpad.net/ubuntu/+source/xdg-desktop-portal-kde/+bug/… ?
    – peter
    Apr 26 '19 at 7:16
  • There are several methods to find out xdg-open calls kde-open5: 1) "ps auxf" :) 2) "mv /usr/bin/xdg-open /usr/bin/xdg-open.orig" and replace it with a bash which calls xdg-open.orig and logs what was started Apr 27 '19 at 1:29

I have a dual boot system with the KDE UBUNTU so i looked for the fonts folder under Windows directory, then copied the thing in fonts directory created in my home although in hindsight could have been left there. So went to the configuration system System Configuration -> Fonts -> there i went to fonts management and added new fonts wizard, navigated to that folder i created and then CTR+A and clicked open and it asked me to skip some fonts and I went with Skip all for those already installed. Bob's you uncle change default to arial form my school assignment and libreoffice cooperates nicely after log out of system and log back in so . thanks for all of this

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.