0

When I run:

libreoffice filename.docx

I get the message:

javaldx: Could not find a Java Runtime Environment!
Please ensure that a JVM and the package libreoffice-java-common
is installed.

LibreOffice still opens normally and works fine.

When I run:

sudo apt install libreoffice-java-common

I get the error message:

The following packages have unmet dependencies:
 libreoffice-java-common : Depends: libreoffice-common (= 1:6.0.3-0ubuntu1) but 1:6.0.7-0ubuntu0.18.04.2 is to be installed
E: Unable to correct problems, you have held broken packages.

I think this may have to do with a problem I solved by uninstalling and reinstalling a bunch of packages to fix similar types of errors. Possibly some dependencies caused different versions of certain packages to be installed?

I'm interested in learning how to fix the error, as well as what the system is doing on a deeper level, so:

What is the meaning of 1:6.0.3-0ubuntu1 and 1:6.0.7-0ubuntu0.18.04.2?

And how would I go about making sure all the dependencies on my system line up properly?

  • if you have synaptic package manager, install it from there. – Graham Apr 25 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.