2

Many of the important icons for the toolbar are missing, like for deletion and going to the next message. Sample image

When I look in /usr/share/evolution/icons/hicolor/ I can't find any file names for the missing icons, so I suspect that's part of it. I just don't see how.

dpkg -l *evolution* gives:

ii  evolution                                      3.28.5-0ubuntu0.18.04.1      amd64                        groupware suite with mail client and organizer
ii  evolution-common                               3.28.5-0ubuntu0.18.04.1      all                          architecture independent files for Evolution
ii  evolution-data-server                          3.28.5-0ubuntu0.18.04.1      amd64                        evolution database backend server
ii  evolution-data-server-common                   3.28.5-0ubuntu0.18.04.1      all                          architecture independent files for Evolution Data Server
un  evolution-data-server-online-accounts          <none>                       <none>                       (no description available)
un  evolution-data-server-tests                    <none>                       <none>                       (no description available)
ii  evolution-ews                                  3.28.5-0ubuntu0.18.04.1      amd64                        Exchange Web Services integration for Evolution
ii  evolution-plugin-bogofilter                    3.28.5-0ubuntu0.18.04.1      amd64                        standard plugins for Evolution (bogofilter)
ii  evolution-plugin-pstimport                     3.28.5-0ubuntu0.18.04.1      amd64                        standard plugins for Evolution (pstimport)
un  evolution-plugin-spamassassin                  <none>                       <none>                       (no description available)
ii  evolution-plugins                              3.28.5-0ubuntu0.18.04.1      amd64                        standard plugins for Evolution
un  evolution-plugins-experimental                 <none>                       <none>                       (no description available)
ii  libevolution                                   3.28.5-0ubuntu0.18.04.1      amd64                        evolution libraries
un  libreoffice-evolution                          <none>                       <none>                       (no description available)
un  syncevolution-libs-gnome                       <none>                       <none>                       (no description available)

I've been all through the menus and the settings, but haven't found anything germane to toolbar icons.

I'm running Ubuntu 18.04.2 w/all the updates.

Edit: one day I noticed they all appeared. Best guess is an update did it.

  • Exact same problem here, Ubuntu 19.04 – AdamS Sep 20 '19 at 15:57
  • @AdamS condolences. In my case, it fixed itself, I suspect after a number of updates – Opux Sep 20 '19 at 19:11
2

If you come to this question running Ubuntu 19.04 then the problem might be because of the new version of Gnome missing icons by default. Other programs are affected too, but Evolution is one of the most obvious.

I found this solution, which I had to adapt slightly - for me the command to solve it is:

sudo aptitude install adwaita-icon-theme-full
| improve this answer | |
  • I think there's something in this. But I don't think this was the exactly solution. I found after selecting different icon themes, it (and a few other things) started working. I guess I was just using a broken theme. – Opux Nov 14 '19 at 15:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.