2

Since upgrading from Kubuntu 18.10 to 19.04, baloo_file_extractor is constantly gobbling up between 30-80% of my cpu and up to 50% of my 8gb ram, making my system slow and unstable.

Running balooctl disable does not seem to stop it, and if I try to kill its process it simply respawns.

In the short term, is there any way to disable it so I can get on with work.

And more generally, should I report this as a bug (have never reported to launchpad before so that I'd check here).

Thanks!

5
  • Open System Settings > Search and disable it there. Does that work?
    – DK Bose
    Apr 24, 2019 at 14:08
  • Also look at System Settings > Startup & Shutdown > Desktop Session and, in On Login, choose to start with an empty session. As for filing a bug, you could use Launchpad or bugs.kde.org
    – DK Bose
    Apr 24, 2019 at 14:13
  • 2
    Thank you, disabling File Search, selecting "Start with an empty session" and restarting prevents baloo from returning. Phew. Silence! I'll go and file a bug. Have a nice day!
    – kokoro
    Apr 25, 2019 at 9:05
  • How were you using baloo in 18.10? What was your experience? Did you only index files or did you index content as well? Did you also add removable / remote devices? I'm mainly on Kubuntu 18.04; there I index both files and content but I've increased what's being black-listed. I've excluded images of all types, .iso files, and media files.
    – DK Bose
    Apr 25, 2019 at 11:16
  • Question: What will I lose from disabling baloo entirely from my system? It appears to be at the root of many of my stability problems.
    – Kelvinator
    Apr 28, 2019 at 6:17

1 Answer 1

1

Beyond disabling baloo, the solution to fixing baloo on my machine was to increase the inotify folder watch limit, as described on the Arch wiki.

sudo nano /etc/sysctl.d/40-max-user-watches.conf

Add the line:

fs.inotify.max_user_watches=524288

Save, then re-enable baloo (assuming it had already been disabled):

sudo balooctl enable; sudo balooctl start

I came across this solution by looking through journalctl --since "1 day ago" and repeatedly finding the line KDE Baloo File Indexer has reached the inotify folder watch limit. File changes will be ignored. A web search of that pointed the way to the solution. Baloo now runs quietly in the background.

Hope that helps anyone else who experiences the same issue.

2
  • I spoke to soon, baloo returned at 100% again. I tried doubling the inotify folder watch limit but the problem still persists. :(
    – kokoro
    Apr 25, 2019 at 10:29
  • Since the inotify route didn't fix the issue, I suggest you add the relevant part of the answer to the question (as your attempt to troubleshoot the issue). Anyway, it's good to see that you're trying to fix the issue rather than disabling baloo completely!
    – DK Bose
    Apr 25, 2019 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.