2

I've been using Ubuntu 18.04 for a while, but a few days ago the wifi signal became weak to the point I can't connect if I'm not really close to the router. Other devices can connect in the same wireless from longer distances. I already tried solutions from other posts, such as this one and this, nothing worked. I suspect it started after an update.

lspci output:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 930M] (rev a2)
02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

lshw -class network output:

*-network                 
       description: Wireless interface
       product: QCA6174 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 32
       serial: 40:49:0f:fe:23:55
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.18.0-17-generic firmware=WLAN.RM.2.0-00180-QCARMSWPZ-1 ip=192.168.1.64 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:127 memory:d5000000-d51fffff
  *-network
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 07
       serial: f4:8e:38:e4:53:89
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:17 ioport:d000(size=256) memory:d5204000-d5204fff memory:d5200000-d5203fff

Thanks in advance

  • Try using an Ubuntu kernel rather than what you are using, 4.15.0-041500-generic is not from Ubuntu as they will be named 4.15.0-20-generic with only 2 digits after the 0 – Jeremy31 Apr 24 '19 at 21:12
  • I'm sorry, this was me trying to fix the problem using other solutions. I actually have two kernels installed: 4.18.0-16-generic and 4.18.0-17-generic, using them didn't solve the problem. – RegularJoao Apr 25 '19 at 9:36
1
+50

The right powersave settings can help out. Check the file:

$ cat /etc/NetworkManager/conf.d/*

[connection]
#wifi.powersave = 3
# Slow sleep fix: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1670041
wifi.powersave = 2

If the setting = 3 then try 2 or vice versa.


For other problems, I wrote this answer two years ago:

Your Wifi card is a Qualcomm Atheros Device [168c:0042] (rev 31). There are many bug reports you can review to find similar problem and recommended solution(s):

In addition to the bug reports, there are problems and solutions posted on various forums:

I have a similar card revealed using lspci -nnv:

3c:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Bigfoot Networks, Inc. QCA6174 802.11ac Wireless Network Adapter [1a56:1535]
    Flags: bus master, fast devsel, latency 0, IRQ 136
    Memory at dd200000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: <access denied>
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci

The same driver ath10k_pci is used as your card. So "one driver fixes all" approach is used for bugs with your card and mine. The one bug I've been following has been fixed but it took two years to reach upstream:

To narrow down which bug effected me most accurately I used dmesg | grep ath10k:

[    3.973278] ath10k_pci 0000:3c:00.0: enabling device (0000 -> 0002)
[    3.974377] ath10k_pci 0000:3c:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    4.253816] ath10k_pci 0000:3c:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:3c:00.0.bin failed with error -2
[    4.253822] ath10k_pci 0000:3c:00.0: Direct firmware load for ath10k/cal-pci-0000:3c:00.0.bin failed with error -2
[    4.254750] ath10k_pci 0000:3c:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:1535
[    4.254752] ath10k_pci 0000:3c:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[    4.255179] ath10k_pci 0000:3c:00.0: firmware ver WLAN.RM.4.4-00022-QCARMSWPZ-2 api 6 features wowlan,ignore-otp crc32 4d458559
[    4.318661] ath10k_pci 0000:3c:00.0: board_file api 2 bmi_id N/A crc32 6fc88fe7
[    4.885699] ath10k_pci 0000:3c:00.0: Unknown eventid: 90118
[    4.886304] ath10k_pci 0000:3c:00.0: htt-ver 3.32 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    4.987424] ath10k_pci 0000:3c:00.0 wlp60s0: renamed from wlan0
[    5.820647] ath10k_pci 0000:3c:00.0: Unknown eventid: 90118

Believe it or not this is today's dmesg after the bug is fixed. The log with the bug can be viewed at the bug report just linked.

I wish there was a one-line answer I could have posted for you but at this point I can only point you in the right direction for doing your homework.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.