0

Yesterday I upgraded my Ubuntu 18.10 to Ubuntu 19.04, and after the restart, the trash icon and my Desktop files have disappeared from the UI. If I go to the Desktop folder from my personal folder, I can see the files, but my Desktop is empty.

How can I show my files in the Desktop again?

0

Install Gnome Tweaks ("Tweaks") from the software center. In Tweaks, click the extensions tab. Find the extension "Desktop icons" and enable it.

If you do not find the extension in Tweaks, it might not have been installed during your upgrade. In that case, install it from software, or with the command sudo apt install gnome-shell-extension-desktop-icons.

Background: In general, upgrading is not the very best way to update an Ubuntu version. An upgrade is not always without issues, in many cases small ones (like this probably), but sometimes major issues. That is why it is not possible to know whether your issue is due to the extension not being enabled, or the extension not being installed.

In 19.04, desktop icons are handled by a rather new Gnome Shell extension instead of by the file manager.

  • I ran the command to install the desktop icons extension and it is now installed but even after re-booting it doesn't appear in the Gnome Tweak Tool. – SteveInBavaria Jul 6 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.