3

When installing davfs2 on Ubuntu bionic, I have got the following errors:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: davfs2 : Depends: libneon27 but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

Then I have to install previous version of libneon27 first to make it right.

sudo apt install libneon27=0.30.2-2build1

  • Is your system fully upgraded? packages.ubuntu.com/… shows 0.30.2-3~ubuntu18.04.1 is the current up-to-date package for 18.04 LTS, so you're either running a out-of-date system (in which case sudo apt full-upgrade) or something else you didn't tell us is at issue. – guiverc Apr 24 at 6:34
  • This happens actually in Vagrant by using ubuntu/bionic64 cloud image "cloud-images.ubuntu.com/bionic/current/…" when first install davfs2. I suppose in this case we don't usually do "sudo apt full-upgrade". – Jason Lo Apr 24 at 7:12
  • Here is my Vagrantfile: Vagrant.configure("2") do |config| config.vm.box = "ubuntu/bionic64" config.vm.box_url = "cloud-images.ubuntu.com/bionic/current/…" end – Jason Lo Apr 24 at 7:21
  • Have exactly the same issue. Ubuntu 18.04 – Tiago Almeida Apr 27 at 12:09
5

I assume this is indeed a known issue confirmed bug 1826063

For know I am trying to configure using an older release of neon27:

sudo apt install libneon27=0.30.2-2build1
sudo apt-mark hold libneon27
sudo apt -y install davfs2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.