0

I have Installed Ubuntu alongside windows 10 by a startup from USB and It is installed perfectly and I got reboot now option. When I rebooted nothing happened and Windows automatically boots itself.

UEFI Firmware setting is not opening when tried from Win10->Settings->Recovery->Advance Start-up->Restart now>UEFI Firmware setting>Restart. After pressing restart nothing happens and windows automatically boots. Tried pressing ESC,F9,F10,F11 and even tried holding shift. after a few key presses, a beep sound comes in a blank screen and windows boots itself after some time or have to shut down by cutting off power. UEFI Firmware setting menu doesn't pop itself(have to shut down completely)

In advance startup from windows 10,Selecting Use a device then Internal Hard Disk partition(row-2,col-2) Though there is no Grub menu while booting, I can select Ubuntu and boot into Ubuntu by selecting the internal hard drive partition which tries to boot Ubuntu for 2-3 seconds and stops at the purple screenStucks here.

  1. expect Ubuntu to start and want to see Desktop.
  2. expect When I need to configure BIOS I can configure it from UEFI Firmware settings which is not opening by itself.
  3. Expect detailed guidance for the above issue.

Thanks in advance...

  • Use ESC (spam it) immediately after powering on. Then a menu should appear. – GabrielaGarcia Apr 24 at 9:59
  • Tried ESC but no menu is appearing, even windows is not booting after that so have to hard shut down! – dbergbrxkisez Apr 24 at 12:59
  • So you have a hardware problem. Accessing BIOS/UEFI is independent of the installed OSes and can even be accessed without any OS or even storage. Speaking of it, if you can remove the HDD/SSD that is worth trying. A defective drive can bork the system to a point the firmware is unaccessible (not usual but it happens). – GabrielaGarcia Apr 24 at 16:30
  • @GabrielaGarcia So, Is there any option to boot into ubuntu or I am just like stuck partitioning my hard drive? – dbergbrxkisez Apr 25 at 13:46
  • I really can't understand your last comment. – GabrielaGarcia Apr 26 at 7:26
0

Almost similar thing happened to me. Running only one command in windows solved this issue for me. Please try doing what is mentioned at the end of this article : Click Here

Note: If after installing Ubuntu, you boot directly in Windows, check in UEFI settings for changing the boot order. If you see no option to set the boot to Ubuntu, you need to fix it from within Windows. When you are in Windows desktop, hover the mouse in left corner, right click and select administrator’s command prompt. Then run the following command:

bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi ​ ​

  • I checked the following link: (itsfoss.com/…) In here Step-5 is to disable secure boot. Now, when I follow the steps mentioned here(itsfoss.com/disable-uefi-secure-boot-in-windows-8) to open UEFI Firmware settings.. After reboot to UEFI Firmware settings the screen stucks(black screen of death). I have tried running this code bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi in administrator from windows cmd. – dbergbrxkisez May 3 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.