1

Running a new install of Kubuntu 18.04 on Dell Optiplex 9020.

My display and audio are connected through a display port to my television. Problem is whenever my machine has been idle for >1 hour, the HDMI audio no longer works. Currently the only fix I have is to reboot the machine.

I have tried the following:

  • Disabling all power-saving settings in System Settings
  • Ensuring everything is unmuted in alsamixer
  • Commenting out the line marked "load-module module-suspend-on-idle" in /etc/pulse/default.pa
  • pacmd set-default-sink alsa_output.pci-0000_00_03.0.hdmi-stereo-extra1 (this does not return an error but neither does it change the default)
  • sudo killall pulseaudio

Extra notes:

  • Logging in and out does not fix the issue, only restarting.
  • Suspending the machine and then unsuspending it does not replicate the issue.

Output when I run pacmd list-sinks

https://pastebin.com/HHjSV4Li

0

Solved the issue, by reading up on DPMS here: https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling#Disabling_DPMS

What ended up working for me was to disable DPMS through xset, with

xset -dpms

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.