0

I have installed Sendmail as my SMTP mail server, SpamAssassin as Spam Classifier and ClamAV Anti-Virus. I tested out sending my server a virus email eicar.txt Now I am receiving the virus email in my mail and not in the quarantine folder. To find out what's wrong, I run the command below:

MailScanner --lint

The output is :

 Trying to setlogsock(unix)

 Reading configuration file /etc/MailScanner/MailScanner.conf
 Reading configuration file /etc/MailScanner/conf.d/README
 Read 868 hostnames from the phishing whitelist
 Read 5807 hostnames from the phishing blacklists

 Checking version numbers...
 Version number in MailScanner.conf (5.1.3) is correct.

 Your envelope_sender_header in spamassassin.conf is correct.

 Checking for SpamAssassin errors (if you use it)...
 Using SpamAssassin results cache
 Connected to SpamAssassin cache database
 SpamAssassin reported no errors.
 mktemp: invalid option -- '-'
 Usage: mktemp [-V] | [-dqtu] [-p prefix] [template]
 Auto: Found virus scanners: clamav 
 Connected to Processing Attempts Database
 Created Processing Attempts Database successfully
 There are 0 messages in the Processing Attempts Database
 Using locktype = posix
 MailScanner.conf says "Virus Scanners = auto"
 mktemp: invalid option -- '-'
 Usage: mktemp [-V] | [-dqtu] [-p prefix] [template]
 Found these virus scanners installed: clamav

 ===========================================================================
 Filename Checks: Windows/DOS Executable (1 eicar.com)
 Other Checks: Found 1 problems
 Virus and Content Scanning: Starting
 mktemp: invalid option -- '-'
 Usage: mktemp [-V] | [-dqtu] [-p prefix] [template]
 ERROR: Option --tempdir requires a non-empty string argument
 ERROR: Can't parse command line options
 ===========================================================================

If any of your virus scanners (clamav) are not listed there, you should check that they are installed correctly and that MailScanner is finding them correctly via its virus.scanners.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.