1

I recently bought the Lenovo 130s-11igm to be a Linux experiment machine. The WiFi adapter it has is the Realtek RTL8821CE wireless PCIE card. After the WiFi not showing up in Ubuntu 19.04 I switched to 18.04 and have been trouble shooting it for a few days now. The Realtek drivers aren't mainlined so there's a repository that has the required drivers for it coming from a forum I found "having the solution" using the code below (connected to ethernet of course.)


sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)

git clone https://github.com/tomaspinho/rtl8821ce
cd rtl8821ce
chmod +x dkms-install.sh
chmod +x dkms-remove.sh
sudo ./dkms-install.sh

The code runs just fine, not giving me any errors. This doesn't fix the issue for me however. Here's a few of the details of my situation.


ideapad_wlan: Wireless LAN Soft block NO, Hard block YES

Wireless LAN: Soft block NO, Hard block NO

Have tried "rfkill unblock all." Doesn't relinquish these blocks.


WiFi settings show up but am unable to turn WiFi on, remains "unavailable", which keeps any networks from being discoverable.


ANSWER:

The fix was was pushing the airplane mode key. Despite being able to toggle it in the settings, it is required to push the airplane mode key on the keyboard. However the above code is STILL required in order to allow the Realtek RTL8821CE adapter to function properly.

4
  • Your wifi seems hard blocked. It means it is blocked by the hardware not by Ubuntu. Is there any network key on keyboard? Try pressing that. Or go into BIOS and check if WiFi is enabled.
    – Kulfy
    Apr 23 '19 at 21:13
  • @Kulfy Thank you so much! There was an airplane mode button that needed to be pushed. Despite being able to turn airplane mode off in settings the button needed to be pushed and I hadn't thought so. For future reference of readers of this post, the above coded is required to make the Realtek RTL8821CE adapter to work properly. Apr 23 '19 at 22:00
  • @Kulfy Also, I am unfamiliar with this forum and am unsure how/if I am the one to assign "The answer" but definitely want credit to be given and for others to possibly see this simple fix. Apr 23 '19 at 22:20
  • @Jeremy31 I can see the possibility of it being a duplicate. I had been searching forums for days and hadn't come across it however. Do I need to take this post down or is it ok leaving it here? Apr 23 '19 at 22:46
0

Start by using the this code.

sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)

git clone https://github.com/tomaspinho/rtl8821ce
cd rtl8821ce
chmod +x dkms-install.sh
chmod +x dkms-remove.sh
sudo ./dkms-install.sh

After rebooting machine you will have access to "WIFI" in settings.

If you have a device that has an "airplane" mode key towards the top of the keyboard press it. While the settings have a way to disable the mode it's required to press the key on the computer. Once this is done you will be able to turn the WIFI on.

Not the answer you're looking for? Browse other questions tagged or ask your own question.