I've tried installing anki with "sudo apt install anki" and it won't launch. I get "NameError: name 'QWebEngineView' is not defined." I also have python3-distutils installed.

Also tried to install Anki from their website. After running "sudo make install," Anki manages to run but then I run into this error.

Error during startup:
    Traceback (most recent call last):
     File "aqt/main.py", line 45, in _init__
     File "aqt/main.py", line 67, in setupUI
     File "aqt/main.py", line 1374, in setupCrashLog
    PermissionError: [Errno 13] Permission denied:'home/ivan/.local/share/Anki2/crash.log'

Had the same error, the following patch fixed it:

Open /usr/share/anki/aqt/qt.py, and change line 13 from:

from PyQt5.QtWebEngineWidgets import QWebEnginePage


from PyQt5.QtWebEngineWidgets import *

Then save the file and that should do it.

Source: https://bugs.launchpad.net/ubuntu/+source/anki/+bug/1825722

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.