0

I'm trying to start syndaemon during boot so it's available from the login window. Nothing has worked, so I have evolved a more and more complicated attempt to try to get at what is going on. Here is where I am at now:

Contents of /etc/rc5.d/S99syndaemon:

#!/bin/bash

/home/michael/syntest &

Contents of /home/michael/syntest

#!/bin/bash

echo "BEGIN" >> /home/michael/synlog
ps aux | grep [s]yndaemon
I=0
while [ "$?" = "1" ]; do
      let I=$I+1
      echo "TRY $I" >> /home/michael/synlog
      syndaemon -d -i 0.5 -R >> /home/michael/synlog2 2>&1
      sleep 1
      ps aux | grep [s]yndaemon
done
ps aux | grep [s]yndaemon >> /home/michael/synlog
echo "END" >> /home/michael/synlog

Permissions:

ls -l /etc/rc5.d/S99syndaemon /etc/init.d/syndaemon /home/michael/syntest
-rwxr-xr-x 1 root root  37 Apr 22 20:59 /etc/init.d/syndaemon
lrwxrwxrwx 1 root root  19 Apr 22 18:24 /etc/rc5.d/S99syndaemon -> ../init.d/syndaemon
-rwxr-xr-x 1 root root 362 Apr 22 20:54 /home/michael/syntest

The log file /home/michael/synlog is not being created.

I also tried both of these commands, to no effect:

sudo update-rc.d syndaemon defaults
sudo service syndaemon start

Why won't my script run? Why isn't synclient being run?

  • From "The log file /home/michael/synlog is not being created." I suspect that /home/michael is an encrypted HOME directory, If df $HOME shows /home/michael/.Private ... it is. Therefore, it is not "mounted" until you login. Store your script somewhere else that is mounted when /etc/rc5.d/* is run, e.g. a directory you create under /usr/local see en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard – waltinator Apr 23 at 4:28
  • @waltinator HOME is not encrypted. I tried several other directories too including /dev/shm initially... my guess was it wasn't mounted yet (but so late in rc5.d???) hence my attempt at a loop as well as other directories. – Michael Apr 23 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.