7

I have an Asus Zenbook 14 with graphics card: Intel Corporation Device [8086:3ea0].

I tried to install ubuntu 19.04 but I'm getting stuck on boot with a purple screen. The install disk also got stuck on a black screen which I fixed by using the 'nomodeset' bypass but it won't work once installed.

Things I tried:

I've gone through hours of these questions and no answer seems to work. I've done all the 'nomodeset' and similar. I have also tried installing Ubuntu 18.10 (which worked) and then upgrading to 19.04 which lead to the same issue. Please note that for some reason, using nomodeset in a specific place worked once, so I know the operating system works fine, but once powered off, I retried the exact same thing and it failed again.

Thanks in advanced.

3

Following worked for me. Very simple but effective till now:

  1. Open terminal with Ctrl+Alt+T

  2. Type sudo gedit /etc/gdm3/custom.conf

  3. Type the password when prompted. (It will not be visible while typing.) edit the file and remove '#' located at the beginning of the following line (its 7th line)

    #Wayland = false
    
  4. So now the line will look like this - Wayland = false

  5. Save and close the window

  6. Exit and restart

2
  • Wonderful! This seems to be the clue. If you install an Nvidia driver in Ubuntu 19.04, you have to deactivate Wayland. I read it somewhere else, but didn't pay attention to this. Thanks! – xarlymg89 Sep 20 '19 at 8:44
  • Thanks! It worked well for me. I have a Lenovo T430s, dual boot with win10. – CrossEntropy Apr 15 '20 at 13:24
2

If anyone else faces this problem, but you cannot access to the terminal because the Nvidia driver, @sangharshs seems to be the clue.

We need to deactivate Wayland, in order to let the Nvidia driver work properly. As it only works with Xorg.

There are some chances that when you install Nvidia, you'll get stuck in a black or purple screen, when booting Ubuntu. If that's the case, then you need to do the following:

  1. Reboot your computer
  2. Select the Advanced options for Ubuntu option, below the "Ubuntu" one, in the Grub panel
  3. Select any of the recovery mode options that you get listed. Doesn't matter what kernel you choose, if you have more than one.
  4. Wait until a new panel appears. And choose the root option.
  5. Edit the /etc/gdm3/custom.conf file with nano, vi or vim. For example: vim /etc/gdm3/custom.conf
  6. Change the line #Wayland = false into Wayland = false (or WaylandEnable instead of Wayland)
  7. Run reboot

That's it! You have Ubuntu running along with the Nvidia driver again.

1

Same exact thing happened is happening to me, I'm on a Zenbook 15 with a Nvidia 1050. Did same things, exactly where you describe you are. I was able to prove that on 18.10, the kernel 4.19.13-generic was 100% working on everything, but wanted to use 19.04 because I wanted the latest gnome-shell + wayland experience. But got the same, even the working kernel and the same params that were working previous to the dist update. Now, one of the differences that I've noticed, is a bump on grub version (also looks like higher res now). so maybe it's a grub thing? I'm trying to boot and rollback to a previous version... BTW, you can see some messages and power off quicker if you add acpi=off and remove quiet splash from the params.

2
  • 2
    IT booted after many many attempts... literately just retrying after each time it got stuck.. maybe after time 15/16. Next time it didn't boot anymore, so after 10 /15 more tries, it did... this is very very weird. I'm trying to rollback to a later grub version, but this time it booted with kernel 5.0.14, nvidia 390 proprietary, and wayland, all running flawlessly smooth.... there's just this issue with booting not working. – Marcelo Mira Apr 27 '19 at 20:24
  • Same story here, I can boot Ubuntu 18.04 once and then, not always working, but usually if I edit grub menu pressing E (even with dummy parameters like foo=bar) I am able to boot. No chance to make 18.10 or 19.04 booting, not even with Try Ubuntu. I have an Asus Zenbook Pro UX480FD. – Marco Cazzaro May 26 '19 at 18:01
1

Well I've finally figured it out. Unfortunately sangharshs answer didn't work for me. But updating the bios did! I found some blog that recommended updating the bios so I went to the Asus support and followed the instructions and now it works! Hope this helps those who were as frustrated as I was.

1
  • Thanks for mentioning about it here. – Bond Sep 7 '19 at 13:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.