-1

Struggling tonight to find basic information on getting a machine back on the network. Wired dhcp no longer works and I can't figure out how to even do a static assignment. I have a wired and wireless card in this machine, installed basic minimal server install from ubuntu-18.04.2-server-ambd64.iso and network did not come up during install. I figured I could troubleshoot once I got it up. Any help on netplan howto / 101 / stupid simple config would be appreciated. I have never heard of it and don't have a lot of time to get this machine connected.

  • If you configure it in the installer, the configuration will carry over to the end system. There should be no meaningful difference between the installer environment and the end system, so configuring DHCP is expected to work (you say it didn't, perhaps the network was still converging after plugging in the wire?) – Mathieu Trudel-Lapierre Apr 23 at 18:11
  • netplan.io/examples would be a good place to start for documentation and help. – Mathieu Trudel-Lapierre Apr 23 at 21:07
  • No, it doesn't seem like the network was converging. I tried part way through the installer three times and finally just completed it assuming there was some esoteric driver issue. So if the config gets copied, then perhaps the issue is it does not auto configure from setup. Either way, this seems like a pretty ridiculous oversight. Why wouldn't the default even include the option commented out if the concern is about assuming too much about the target network. It just seems the most 80% case (60, 50?) should be covered in some better way. – Peter Oehlert Apr 24 at 3:07
  • Also, much appreciated to whoever down-voted. I'm not sure what issue you have here but this is a legitimate question, asked in a detailed and objective way about a common misunderstanding as people are exposed to a new default technology. I continued to research my question and answered it myself in the simplest possible fashion. I'm not sure what you might find objectionable other than suggesting the choice of this configuration is questionable. But thanks all the same. – Peter Oehlert Apr 24 at 3:11
0

Kind of unbelievable you have to go learn a new subsystem to get something so completely basic running. This seems like a terrible choice. Adding the ethernets: section to the default .yaml file and then running sudo netplan apply seemed to get an IP address assigned.

network:
  version: 2
  renderer: networkd
  ethernets:
    enp3s0:
      dhcp4: true
  • Configuration files should have come with a comment saying this is netplan and how to get more information. There should also have been a similar comment in /etc/network/interfaces. Are you saying this was not the case? If so, that would be a bug that needs to be filed so we can fix it. – Mathieu Trudel-Lapierre Apr 23 at 18:14
  • It's not that the comment was not there, it's just that there is no efficient way to divine how to accomplish getting a basic network config set up from the system alone, without using the network that it can't connect to. I'm just surprised that the default setting requires configuration in the most basic of cases of scenarios of plugging in a wired network cable. It's been a couple of decades since that hasn't worked out of the box and not sure why the regression seems like a good idea. – Peter Oehlert Apr 24 at 3:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.