1

I was having some issues with my laptop connecting to wifi, so I decided just to reinstall the OS. I made a backup with Duplicity and moved it to my phone, made a fresh install of Ubuntu 18.04, then moved the backup back onto my laptop to restore.

I've done this before, but this time things didn't go as smoothly. I went through the restore dialogues, and as it started restoring there was an error:

Restore Failed

Failed with an unknown error.

Traceback (innermost last):
  File "/usr/bin/duplicity", line 1555, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1541, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1393, in main
    do_backup(action)
  File "/usr/bin/duplicity", line 1472, in do_backup
    restore(col_stats)
  File "/usr/bin/duplicity", line 728, in restore
    restore_get_patched_rop_iter(col_stats)):
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 558, in Write_ROPaths
    for ropath in rop_iter:
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 521, in integrate_patch_iters
    for patch_seq in collated:
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 389, in yield_tuples
    setrorps(overflow, elems)
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 378, in setrorps
    elems[i] = iter_list[i].next()
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 121, in difftar2path_iter
    tarinfo_list = [tar_iter.next()]
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 339, in next
    self.set_tarfile()
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 333, in set_tarfile
    self.current_fp = self.fileobj_iter.next()
  File "/usr/bin/duplicity", line 764, in get_fileobj_iter
    backup_set.volume_name_dict[vol_num],
 KeyError: 1

I need to fix this urgently, and I'll provide updates if I discover anything, but I'll I can really do is look up the error and see if anyone else has experienced it. I'm not sure what's going on.

I ran

LANG=C DEJA_DUP_DEBUG=1 deja-dup --restore

which, after successfully detecting all my old snaps (it said DUPLICITY INFO 'home/user/snap/app/...), created the following output with errors. I really need my files back, and I don't know what happened to create such a huge error.

1

Problem solved:

Update 1 I reinstalled again, but got the same errors. I found this article helpful, and I was able to extract all the duplicity files into their incremental pieces. The article says to use rdiff to stitch together the files, but I'm not sure how easy that will be. Luckily my Lab Report that I really needed to restore was left intact. I'm going to try and fix the rest of the files next.

Update 2 I couldn't restore my backup using Deja-Dup, so I had to manually extract everything. I followed this guide to restoring by hand, and some of my files are back, but others that spanned multiple duplicity volumes were separated into incremental files. The wiki says "To recover data from incremental backups, use rdiff to stitch the files together." but I'm having difficulties.The rdiff manual has a section on restoring from incremental files, but I couldn't figure it out. I found another thread about manual restoration, and in it someone provided a script for joining multivolume snapshops. I ran the script, and all the multivolume snippets were joined. I got my files back.

  • Answers go into the answer section... ;-) +1 to both Q and A and figuring it all out yourself; Ask Ubuntu is not really a good place for time-sensitive questions... – Fabby Apr 27 '19 at 7:14
0

try --ignore-errors as explained here and/or restoring with duplicity on the command line.

..ede/duply.net

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.