15

After upgrading from 18.04 to 19.04 (with a necessary upgrade to 18.10 between) on a Lenovo Yoga 11e, I can no longer drag and drop anything (ie, files, windows, etc.) with the touchpad. I can, however, move things around using the touchscreen. Whenever I attempt to do so with the mouse, though, sometimes it turns into a hand. Whether or not it turns into the hand or remains a pointer, the icon will not move anymore. IOW, as soon as I left-click, the pointer freezes in place until I release the touchpad.

  • 1
    I am using mouse only. And the drag-and-drop functionality stopped working after upgrade to 19.04. I have tested between Files (Nautilus), Thunar and Archive Manager and nothing is working. The mouse cursor turns into hand (and sometimes with the plus sign) but nothing is copied or moved after I release the mouse button. – FedonKadifeli Apr 23 at 10:15
  • 1
    Please note that, dragging a file from Nautilus or Thunar to Archive Manager does work. The problem is with the other way around. – FedonKadifeli May 18 at 14:46
10

Yup: https://gitlab.gnome.org/World/ShellExtensions/desktop-icons/issues/22

Just the most recent installment of the long, proud tradition of new GNOME releases breaking significant functionality used by many people. "Move fast and break things," and all that. sigh

  • 1
    Although this is not an answer to the problem, I have to agree with you that many GNOME-related things broke after the update from 18.10 to 19.04. :( – FedonKadifeli Apr 23 at 19:15
  • 3
    One of the reasons many people are sticking with the Unity desktop in the forseeable future. – WinEunuuchs2Unix Apr 23 at 19:39
  • Are there any news or any hope that this problem will be solved in Ubuntu 19.04? – FedonKadifeli May 18 at 13:49
  • 1
    While I do not necessarily disagree with the notion that GNOME developers often tend to break things, the second paragraph presents nothing but mere rhetoric without any factual details. GNOME developers did present a detailed list of reasons behind the decision, see here. If one goes through it thoroughly, it would be clear that this is not a simple issue of breaking things on a whim. – pomsky May 22 at 15:56
  • 1
    I am not sure that this problem is related to GNOME desktop. The real problem is that Nautilus and Thunar windows do not accept drag and drop actions from other windows like Archive Manager. But, the reverse works: Nautilus and Thunar can start drag and drop actions to other windows like Archive Manager. – FedonKadifeli May 22 at 17:37
2

I've found a fix for this; you have to disable the experimental views. It can be done in the terminal by running:

gsettings set org.gnome.nautilus.preferences use-experimental-views false
  • Is gsettings set org.gnome.nautilus.preferences use-experimental-views false the command to execute in the terminal? – Yufenyuy Veyeh Dider May 28 at 9:23
  • 1
    It was already false (the default value). Experimented also by changing it to true and then back to false, but nothing changed. – FedonKadifeli May 28 at 9:29
  • This fixed my issue. Thanks. How did you figure this out? – Anthony Jul 1 at 15:33
  • Thanks, worked for me. Broke due to 18.10 to 19.04 'upgrade' – Jason Morgan Oct 17 at 21:19
1

I am using Ubuntu 19.10 and have found another extension Desktop Icons NG (DING) by rastersoft which allows the contents of .~/desktop to be seen on the desktop. It also allows new folders to be made on the desktop via a right-click on the mouse and to drag and drop from Nautilus folders onto the desktop. It does not allow dragging from the desktop and dropping into a Nautilus folder.

0

The problem in 19.04 is that you can no longer use the traditional Desktop to store frequently accessed single items or single files.

You can enable a home folder icon, and a trash icon, by the use of the Desktop Icons GNOME extension found here. It's feature limited right now, but it's expected that its feature set will be expanded in the future.

You can however, use folders on the Desktop. Use Files (Navigator) to create a folder on your current Desktop called... say... Work in Progress. Then drag all individual items/files from the current Desktop into this new open folder.

Now you can drag and drop files/items {in to | out of} this open folder as you could before. D&D files/items on to other app icons should also work via folder to folder D&D. Of course, you can also right-click on a file and use the Open with contextual menu item.

Think of the Work in Progress folder as the "new" Desktop in 19.04. Anything that you could do in the 18.xx Desktop, you should be able to do in the open Work in Progress folder in 19.04.

Update #1:

A note from user FedonKadifeli...

*A note: The problem described here occurs when I login to a GNOME desktop session (the default in my installation). I tested and found that it does not occur when I login to an Ubuntu desktop session. So, this may be the difference between your case and my case.

  • 1
    I am sorry, but this is not very related to the problem described here. The problem is that you can not DnD a file from a window of Archive Manager to a Nautilus window (e.g. into a folder). As another test case, I created a folder called Work in Progress (as you described above) on my desktop and tried to DnD a file from Archive Manager onto this icon (on my desktop): It didn't work either. However, when I crate an empty file in the folder Work in Progress, open the folder with Nautilus and DnD this file onto an open Archive Manager window it does work. – FedonKadifeli May 22 at 17:23
  • 1
    @FedonKadifeli It just worked for me. I opened the Work in Progress folder. I opened Archive Manager showing a .deb file. I dragged the control.tar.xz file directly into the open Work in Progress folder. No need to create another folder/file inside the Work in Progress folder. Notice how I said "Then drag all individual items/files from the current Desktop into this new folder", and "drag and drop files/items {in to | out of} this folder"? Do I need to say "open" folder? – heynnema May 22 at 18:40
  • Can you elaborate on the versions of the programs (Nautilus, Archive Manager) you are using? Mine are given in the bounty text above. Are you on version 19.04 of Ubuntu? I also had no problem in the previous version of Ubuntu. – FedonKadifeli May 22 at 19:13
  • @FedonKadifeli 19.04. Same versions of Archive Manager (File Roller) and Nautilus. Think of the Work in Progress folder as the "new" Desktop. Anything that you could do in the 18.xx Desktop, you should be able to do in the open Work in Progress folder. Please confirm, then maybe reverse your down vote :-) – heynnema May 22 at 19:22
  • 1
    @FedonKadifeli your fault is with step 9... you don't drag control.tar.xz to the work folder icon on the desktop (that will fail)... you drag it to the open work folder window. If there's a difference between GNOME desktop and Ubuntu desktop I can't say, but if you've already seen a difference, then as you say... it all works as I describe in my answer. Maybe you should be using Ubuntu desktop? How's that for a workaround? :-) – heynnema May 22 at 20:36
0

I am not sure if my problem orginated from exact scenarios but I was not able to drag and select anything in my system - neither in my browser, or in editor or in file navigator. The drag rectangle was not appearing or text was not getting selected.

It was working earlier so I had to figure out what happened that led to this. I had recently installed gnome-tweaks and had changed mouse settings to enable the right click emulation on the touchpad according to this.

https://itsfoss.com/fix-right-click-touchpad-ubuntu/

I went and disabled that option and switched to mouseclick emulation with fingers. That seems to have solved my issue.

I found a couple of related issues. Thought I should tag all of them here

Drag & drop does not work on Ubuntu desktop https://unix.stackexchange.com/questions/423543/drag-and-drop-not-working-in-gnome3-file-manager-selects-multiple-files-instead https://www.reddit.com/r/Ubuntu/comments/bhgte9/help_freshly_installed_1904_and_cant_drag_and/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.