14

After updating from Ubuntu 18.10 to 19.04 under Xfce, the terminal can not be started from the Panel.

Failed to launch preferred application for category TerminalEmulator. Failed to execute child process /usr/lib/x86_64-linux-gnu/xfce4/exo-1/exo-helper-1 (No such file or directory).) Directory exo-1 does not exist.

The same error messages occurs when trying to start other preferred applications from the application list.

How can this problem be solved?

3 Answers 3

19

Had the same problem. The bug was reported in the Debian bugs list

sudo apt install libexo-1-0

worked for me.

4
  • I have the same issue since upgrading to Ubuntu 19.04 but for me this does not resolve it as I get this error: E: Package 'libexo-1-0' has no installation candidate. It suggests I install libexo-helpers but this is already installed and attempting to remove it wants to remove XFCE. I have already tried removing and reinstalling XFCE to no avail. Is there any other workaround? May 10, 2019 at 0:31
  • @RobinWilson: XFCE depends on GTK-2 or on GTK-3. GTK-2 uses libexo-1-0, GTK-3 uses libexo-2-0. Ref: packages.ubuntu.com/source/disco/exo. Do you have the latest version of exo (which has both libs)? Jun 3, 2019 at 18:10
  • 1
    @PeterStuart: Thanks but I tried to install exo but it cannot find it: sudo apt install exo. Is it referred to by another name? It all worked with 18.10 which was a newly installed server. Jun 4, 2019 at 19:10
  • Worked for me (on 19.04).
    – Adam D.
    Oct 9, 2019 at 11:46
10

I fixed this by installing xfce4-settings with the following command:

sudo apt install xfce4-settings 
0
1

I'm having the same problem on Debian 11 (Bullseye) and I have managed to fix it by creating a symbolic link to /lib/x86_64-linux-gnu/xfce4/exo-2/exo-helper-2 (which exists in my system) from /lib/x86_64-linux-gnu/xfce4/exo-1/exo-helper-1 (which Xfce is looking for).

Although it seems to be working fine, I cannot say if the programs behave in any different way so proceed at your own risk. Creating the file and folder manually may also cause some conflicts later on if your package manager tries to manipulate those paths - probably nothing grave or that you couldn't fix relatively easily anyway.

I have all the libexo-* exoutils libexo-helpers packages installed and up-to-date for my architecture so it doesn't seem to be a missing package issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .