1

Within the last day or two, my sound has stopped when using the GUI (GNOME).

On the log-in screen I can click on the icons in the top right and see a speaker icon and a brightness icon. The speaker volume can be adjusted and makes a small blip as I adjust it.

By the time the GNOME session has started the same icons in the top right show a microphone and brightness icon but the top line, although it has a slider, shows no speaker icon. Opening Settings/Sound shows the Output volume greyed out and the box under 'Choose a device for sound output' is blank. It is as if the GUI is not aware of the existence of the internal speakers.

Using Ctrl-Alt-F1 I can revisit the log-in screen and still get the proper slider and audible blip.

Although I have been doing some tweaking using the Command Line in the last 48 hours, including setting up a new user, I have not (to the best of my knowledge) done anything to disturb the audio set up. e.g. I played a little with .bashrc to customise my command line.

I cannot pinpoint exactly when the sound ceased to work but I think it was less than 24 hours ago. I have tried removing and re-installing alsa and pulseaudio. And of course I have rebooted several times but to no effect.

This may also be relevant: A few minutes after I log in to a new GNOME session I get a message to say System Error detected - I didn't get this message before I noticed the lack of sound.

UPDATE: I have tried once more to remove and re-install alsa-base and pulseaudio. This has lost me the 'blip' on the log-in screen. The display is the same as in the GUI - three sliders with icons (none); microphone; brightness.

I know the speakers are working because with just alsa-base installed I can use mplayer on the command line to play an mp3 file. If I install pulseaudio it refuses to play. If I remove pulseaudio again it plays OK. In either case there is no sound when I return to the GNOME interface.

UPDATE 2: In an attempt to get around the problem I upgraded my version of Ubuntu from 18.04 to 18.10 and the problem remains! I can still play an mp3 file from the command line using mplayer (without pulseaudio installed). With pulseaudio I get

========================================================================== Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III AUDIO: 44100 Hz, 2 ch, s16le, 320.0 kbit/22.68% (ratio: 40000->176400) Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III) ========================================================================== AO: [pulse] Init failed: Access denied Failed to initialize audio driver 'pulse' [AO_ALSA] alsa-lib: pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

[AO_ALSA] Playback open error: Connection refused Failed to initialize audio driver 'alsa' [AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le [AO SDL] using aalib audio driver. [AO SDL] Unable to open audio: No available audio device Failed to initialize audio driver 'sdl:aalib' Could not open/initialize audio device -> no sound. Audio: no sound Video: no video

Checking the Settings/Sound again I've found that I can now play one of the Sound Effects (drip, bark etc) by clicking on it to get an audible noise. But the Alert Volume is greyed out and there are no devices listed under either Output or Input. However, by opening a Terminal Window within GNOME I can use mplayer to play music and video (with sound), which suggests the problem is software related and not a malfunctioning speaker.

1

After further searches about this problem and a few more futile attempts to solve it for myself, it was one of the following instructions which seemed to work:

sudo apt remove indicator-common

sudo apt autoremove

Having re-booted after these two commands my sound (and speaker indicator) re-appeared. There is no longer a microphone indicator, although the microphone does show up in the Settings now.

I suspect, but am not certain, that it was removing the indicator-common package which solved the problem. I have not yet tried re-installing it. And it could be that something from my earlier attempts was the solution, which I didn't notice until the re-boot.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.