0

I have a Lubuntu installed on a Mac Mini with dual boot.

$ uname -a
Linux platolinux 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Wifi can connect without problems, but Ethernet connection does NOT work

When I boot, the ethernet interface seems to be down. When I start the computer and check hardware with lshw I get the ethernet interface as DISABLED

$ sudo lshw -c network -sanitize
[sudo] password for plato: 
  *-network                 
       description: Wireless interface
       product: BCM4360 802.11ac Wireless Network Adapter
       vendor: Broadcom Inc. and subsidiaries
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 03
       serial: [REMOVED]
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=[REMOVED] latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:18 memory:a0600000-a0607fff memory:a0400000-a05fffff
  *-network DISABLED
       description: Ethernet interface
       product: NetXtreme BCM57766 Gigabit Ethernet PCIe
       vendor: Broadcom Inc. and subsidiaries
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0f0
       version: 01
       serial: [REMOVED]
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=57766a-v1.15 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:19 memory:a0700000-a070ffff memory:a0710000-a071ffff

I bring it up with

sudo ip link set dev enp3s0f0 up

then I get this

$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether 78:7b:8a:b8:c8:35 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DORMANT group default qlen 1000
    link/ether 8c:85:90:f0:5d:fe brd ff:ff:ff:ff:ff:ff

checking network interfaces says that the ethernet interface () does not get a ipv4

$ ifconfig
enp3s0f0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::7a7b:8aff:feb8:c835  prefixlen 64  scopeid 0x20<link>
        ether 78:7b:8a:b8:c8:35  txqueuelen 1000  (Ethernet)
        RX packets 305  bytes 38637 (38.6 KB)
        RX errors 0  dropped 2  overruns 0  frame 0
        TX packets 27  bytes 4160 (4.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 19  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1920  bytes 195426 (195.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1920  bytes 195426 (195.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.44  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::1567:dcbd:6c9a:ea0c  prefixlen 64  scopeid 0x20<link>
        ether 8c:85:90:f0:5d:fe  txqueuelen 1000  (Ethernet)
        RX packets 13406  bytes 8630835 (8.6 MB)
        RX errors 0  dropped 0  overruns 0  frame 3603
        TX packets 13526  bytes 2034742 (2.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18  

Any help will be appreciated, I have been three days reading and searching without success

1

I guess you can get IPv4 if you restart NIC and turn off IPv6.

sudo ifdown [interface name] && sudo ifup [interface neme]

For your case, the interface neme is enp3s0f0.

Please add

net.ipv6.conf.all.disable_ipv6 = 1

net.ipv6.conf.default.disable_ipv6 = 1

net.ipv6.conf.lo.disable_ipv6 = 1

to

/etc/sysctl.conf

and then type the following command and press Enter on a command line

sudo sysctl -p

Next, please create a new file /etc/rc.local and add these contents

#!/bin/bash
# /etc/rc.local

# Load kernel variables from /etc/sysctl.d
/etc/init.d/procps restart

exit 0

and give the permission to execute to the file

chmod 755 /etc/rc.local
  • Thanks Mr Robot. I 'll give it try that later today but I am afraid it may not be sufficient becasue the ethernet interface is not enabled after start up. (see the reult of: lshw -c network -sanitize, where wireless is ENABLED while ethernet is DISABLED after booting and this happens everytime). – PlatoWright Apr 23 at 14:39
  • Then please try restart NIC first as I added:) – MR. ROBOT Apr 23 at 15:02
  • Please tell me if it does not help you. – MR. ROBOT Apr 23 at 15:20
  • Mr Robot. I did follow your recommendations and after reboot it worked fine. thank you so much. now the interface is enabled from start and a ipv4 is assigned. THANKS – PlatoWright Apr 24 at 20:04
  • I am glad to hear it:) Please click the check mark so that everyone can understand that this problem is solved and the solution is valid :) – MR. ROBOT Apr 25 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.