6

After upgrading to Ubuntu 19.04, I have noticed a visible freeze of a couple of seconds whenever I click a button of a Gnome dialog window. One case when it appears is the screen unlock window, but even the "open file" dialog in most applications gives the same behaviour.

Journalctl displays some error messages that appear to be related [EDIT: the messages were a red herring apparently; they do not appear at the same time as the bug happens.]

Any ideas as to what could be causing it? Is it a known problem? Any experiment

  • 1
    Please check this: askubuntu.com/questions/1135671/… – Amandeep Singh May 9 '19 at 5:10
  • 1
    Same happens on my system and it started after updating to 19.04 from 18.10. My system uses an amd graphics card and the experimental amdgpu driver, so I should probably test with the default radeon driver. Also I have installed this system in 2012 and only upgraded to newer versions since then without reinstalling, so maybe that's an issue. Let me know if you find a cause for this. Edit: Just noticed it doesn't happen when using a new user account. So probably something related to my home directory. – w-flo May 27 '19 at 10:52
  • 1
    @w-flo No solution yet, but the problem seems to get worse the longer Gnome runs, so for now my workaround is restarting Gnome (alt+F2-r-enter) every now and then. – Federico Poloni Jun 7 '19 at 6:14
  • 1
    disable gnome-shell-extension-desktop-icons I believe it is named so. Make sure no Icons are shown on Desktop. Any difference between wayland or X11 session? – nobody Jul 25 '19 at 18:13
  • 1
    No, found only bugs.launchpad.net/ubuntu/+source/… and thought this could be the Problem. – nobody Jul 25 '19 at 18:38
2
+50

I turned out, that the freezes are a product of a bug in gnome-shell-extension-desktop-icons is.

@Federico Poloni found his own workaround.

Go fishing is a good thing :D

  • I'm also having this issue and I actually tried just last week to disable the Desktop Icons extension (by logging in to the vanilla Gnome session), and the issue still occurs. – Logix Jul 26 '19 at 12:35
  • Then you have another Problem as @Federico Poloni please make your own thread and mention that this solution is not working in your case. – nobody Jul 26 '19 at 12:37
  • Thank you for the ping Federico and thanks nobody for that pointer, removing that package from my system solved my issues! At least it looks that way right now after a fresh boot. Who needs desktop icons anyway? Will re-install before upgrading to 19.10 to hopefully see it fixed then. – w-flo Jul 30 '19 at 9:46
0

Do you use an Nvidia Optimus with modeset enabled? In my case setting modeset=1 for nvidia_drm module causes intermittent freezes. You can try disabling it.

  • 1
    No, I have an Intel i915 and no particular kernel boot parameters. Thanks for the attempt though! – Federico Poloni Apr 28 '19 at 15:15
  • 1
    I have the exact same issue. and same graphic card. – Luka Jun 7 '19 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.