1

I bought a windows laptop that uses 128GB SSD + 1TB HDD. Windows was pre-installed on the SSD. I installed Ubuntu on the HDD.

But the GRUB boot loader does not appear and the laptop automatically boots into Ubuntu. To access Windows, I have to press F12 while the laptop on to use the UEFI boot loader.

How can I get GRUB working so the option to boot into Windows appears without having to press F12every time I start my laptop?

I also noticed that while installing Ubuntu, the option to install ubuntu alongside windows did not appear and I had to use the something else option to manually partition the disk.

Edit 1: Result of sudo grub-update

Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.0.0-13-generic
Found initrd image: /boot/initrd.img-5.0.0-13-generic
Adding boot menu entry for EFI firmware configuration
done

Edit 2: When I used Boot Repair, Recommended repair, GRUB showed up without Windows. I think Ubuntu can’t detect windows.

Image of Grub

Edit 3: Boot Repair Summary

  • Boot into ubuntu and type sudo update-grub,then post a screenshot of the output. That way we can see if windows gets detected at all by grub. – ThonkDifferent Apr 22 '19 at 10:58
  • Also, you didn't see the "install alongside windows" because on the HDD was no operating system, therefore the installer did not suggest you this option – ThonkDifferent Apr 22 '19 at 11:02
  • The "install alongside windows" problem could also be because your windows partition don't precise that it's windows – Jerare Apr 22 '19 at 11:12
  • 1
    I changed to ACHI, hit boot repair and switched back to RAID. It works now. Thanks @GabrielaGarcia – Soham Apr 23 '19 at 8:01
  • 3
    @Soham Welcome to Ask Ubuntu! Please don’t add “SOLVED” to the title. If you solved your problem, post an answer instead. – Melebius Apr 23 '19 at 8:04
2

This answer was originally posted by the asker as an edit to the question and a comment.

Switch to AHCI, run boot-repair and switch back to RAID.

  • After switching to AHCI, OP ran boot-repair then switched back to RAID. At least that's the way I read the comment... – WinEunuuchs2Unix May 13 '19 at 10:41
  • @WinEunuuchs2Unix You are right, I forgot about that comment when I created this answer. It‘s updated now, please check it and feel free to edit. – Melebius May 13 '19 at 19:46
  • Looks good to me and I upvoted. Thanks. – WinEunuuchs2Unix May 13 '19 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.