6

After upgrading to Ubuntu 19.04 my GRUB menu doesn't not show up.

Instead, it halts for 10 seconds and then directly boots up to 19.04 although I have installed Windows 10 alongside (Dual booted).

GRUB menu was working perfectly when upgrading to 18.10 from 18.04LTS.

Also, if I press Esc or Shift key it hangs and then I have to press power button to start the laptop again.

marked as duplicate by karel, Eric Carvalho, Fabby, Kulfy, Pablo Bianchi May 6 at 15:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Probably the Ubuntu 19.04 installation has added its own EFI boot entry, configured to not show the grub menu.

Try this: edit the file /etc/default/grub to make sure the GRUB_TIMEOUT value there is set to something larger than zero, for example GRUB_TIMEOUT=12 if you want the menu shown for 12 seconds. Then run the update-grub command:

sudo update-grub

The output from the update-grub command should say "Found linux image" and if you have Windows 10 installed it should also say "Found Windows Boot Manager". Then reboot, and the grub menu should be shown.

  • This does not work for dual boot system. I even set grub timeout to 0 or even left it blank nothing happens really in dual boot system (I get 10s timeout always) there must be something else that configures grub on dual boot system. He might have done something terribly wrong while upgrading to 19.04. – Saurabh Singh Apr 29 at 18:59
0

The Boot Repair Utility usually fixes problems related to booting.

Assuming you can boot into your Ubuntu Session and have access to it:

1.Install Boot-Repair in Ubuntu

  • either from an Ubuntu live-session (boot your computer on a Ubuntu live-CD or live-USB then choose "Try Ubuntu") or from your installed Ubuntu session (if you can access it)

  • connect to the Internet

  • open a new Terminal, then type the following commands (press Enter after each line):

    sudo add-apt-repository ppa:yannubuntu/boot-repair sudo apt-get update sudo apt-get install -y boot-repair && boot-repair

Using Boot-Repair

launch Boot-Repair from either :

  • the Dash (the Ubuntu logo at the top-left of the screen) or by typing 'boot-repair' in a terminal
  • Then click the "Recommended repair" button. When repair is finished, note the URL (paste.ubuntu.com/XXXXX) that appeared on a paper, then reboot and check if you recovered access to your OSs. If the repair did not succeed, indicate the URL to people who help you by email or forum.

To see full details of what it is, how to download and use it, see: Boot Repair. This must fix your problem.

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Mr Shunz Apr 23 at 8:23
  • @MrShunz Thanks for pointing out. ( But because the link refers to an Official Documentation it is less likely to be changed anytime soon. ) Yet I have edited my answer, adding in the essential parts. – Milkybar Apr 23 at 14:58
0

i encountered this myself some time back, i don't remember exactly what i did to fix it and i don't have access to a ubuntu system right now to double-check, but iirc here's what i did:

in /etc/default/grub (or was it /etc/default/grub.cfg ? whichever one of those exists)

  • make sure GRUB_TIMEOUT is set to something higher than 0, like GRUB_TIMEOUT=5
  • make sure GRUB_TIMEOUT_STYLE is set to menu, eg GRUB_TIMEOUT_STYLE=menu
  • remove all references to GRUB_HIDDEN

then run sudo update-grub (or sudo grub-update , don't remember which) and reboot, and the grub menu should pop up

0

I had the same issue.

sudo update-grub showed the second OS, but at boot, same problem.

I tried the other suggestions like adding GRUB_TIMEOUT_STYLE=menu, and tried installing boot-repair, neither worked.

What did work was installing grub-customizer. In "General Settings" you can select the default OS, but what made the difference for me was in "Appearance Settings". By selecting a font, the grub menu showed up.

Not the answer you're looking for? Browse other questions tagged or ask your own question.