7

Is there a way to set a region of my touch pad as "dead" ignoring touch input?

The reason for this is that I have a MacBook pro late 2011 and there the "button" is on the touch page itself.

Anyone got any ideas? :D

11

You could try using a combination of something like the following to disable strips on the sides, top and bottom of the touchpad.

synclient AreaLeftEdge=w AreaRightEdge=x AreaTopEdge=y AreaBottomEdge=z

To figure out what w,x,y and z would be, you'll need to know the range, or boundaries of the touchpad, which might show in the Xorg log, as in my case. I don't have a Macbook, but an example will do to illustrate the method.

To find out the touchpad boundaries, run less /var/log/Xorg.0.log | grep -i range. Here is the output I get:

(II) ETPS/2 Elantech Touchpad: x-axis range 8 - 1144
(II) ETPS/2 Elantech Touchpad: y-axis range 8 - 760

UPDATE:

If for some reason, the above command no longer works because Xorg.0.log has changed location, you would also be able to get edge coordinates from synclient directly.

synclient

gives:

LeftEdge                = 8
RightEdge               = 1144
TopEdge                 = 8
BottomEdge              = 760

UPDATE-END

Now, to disable strips on both sides and at the bottom, I've added the following to autostart applications:

synclient AreaLeftEdge=50 AreaRightEdge=1100 AreaBottomEdge=670

It took some trial and error to adjust the widths to comfortable levels, so you might what to experiment in a terminal window first, before adding it to autostart. The changes are applied instantly.

| improve this answer | |
  • Thanks. My rightpalm was the bain of my typing existence. Setting AreaRightEdge work brilliantly. I would add one thing to your answer, you're able to get the exact coordinates of the edge from synclient itself. – thebunnyrules Dec 25 '17 at 17:37
  • Doesn't solve my problem:when part of my palm rests of the left edge (accidentally) it blocks scrolling with the right hand. This blockage seems to keep happening even when I define a dead left reigon – relG Aug 30 '18 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.