I'm on Ubuntu 18.04 and I'm able to setup a wifi hotspot in the UI (as described for example here) which works perfectly. I now want to change the SSID and the password of the hotspot. I tried doing this using the UI which you get when running nm-connection-editor. Changing the password works, but somehow the SSID is reverted to the default name (librem) after starting the hotspot again.

I confirmed this by looking at the file /etc/NetworkManager/system-connections/Hotspot. I manually changed the ssid in that file to myawesomehotspot. I then rebooted the whole machine to make sure the default name isn't cached anywhere. And then I enabled the hotspot in the wifi settings screen again. Upon checking, the ssid in the file /etc/NetworkManager/system-connections/Hotspot was changed/overwritten with the default name librem again (the file datetime also showed that it was rewritten).

Why does opening the hotspot overwrite the ssid? Where does this name come from? And how can I permanently rename the hotspot? All tips are welcome!


The outputs as asked by @Marmayogi in the comments:

$ nmcli device
DEVICE           TYPE      STATE      CONNECTION      
wlp1s0           wifi      connected  Hotspot         
br-63805314ad4c  bridge    connected  br-63805314ad4c 
docker0          bridge    connected  docker0         
lo               loopback  unmanaged  --              

$ networkctl status
WARNING: systemd-networkd is not running, output will be incomplete.

●        State: n/a
       Address: on wlp1s0
       on br-63805314ad4c
       on docker0
                fe80::fa30:17ec:448:579a on wlp1s0

$ sudo lshw -short -class network
H/W path                 Device           Class          Description
/0/100/1c/0              wlp1s0           network        AR9462 Wireless Network Adapter
/1                       docker0          network        Ethernet interface
/2                       br-63805314ad4c  network        Ethernet interface

$ ls -l /etc/resolv.conf
lrwxrwxrwx 1 root root 39 Mar 11  2018 /etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf
  • Please edit your question and post output of the following commands: 1. nmcli device, 2. networkctl status, 3. sudo lshw -short -class network, and 4. ls -l /etc/resolv.conf. Thanks.
    – Marmayogi
    Apr 22, 2019 at 4:42
  • @Marmayogi - I've added the outputs to the question. Does that help?
    – kramer65
    Apr 22, 2019 at 7:22
  • I Just changed my SSID on my desktop Wi-Fi, it worked fine! Settings -> Wi-Fi -> Cog icon -> Identity -> SSID. Change SSID. I had no problems (Me too on Ubuntu 18.04) . I wanted to see the status of your WiFi connected with Hotspot device, your IP as well as Nameserver IP. From the ouput you posted, it seems that everything is fine. Did you try Settings? Have you configured /etc/netplan/yaml file by any chance?
    – Marmayogi
    Apr 22, 2019 at 9:02
  • @Marmayogi - I'm unsure what cog icon you mean. I only tried changing the hotspot ssid with nm-connection-editor and in the Hotspot file. Would you be so kind to show me a screenshot of the cog icon you're talking about?
    – kramer65
    Apr 22, 2019 at 13:50
  • i.stack.imgur.com/6iQRd.png Mouse Pointer in this pic shows cog-wheel
    – PRATAP
    Apr 22, 2019 at 14:16

2 Answers 2


Note: this workaround does not answer the actual question Why does changing the hotspot SSID not work?


  1. When the hot spot is turned on via GUI, it automatically takes the input from Device name

enter image description here

enter image description here

  1. If i change my Device name, the same name will be generated when the hot spot is turned on via GUI.

enter image description here

enter image description here


as you mentioned that you have edited the file /etc/NetworkManager/system-connections/Hotspot, I have tried to change its permissions in several ways but it always overwritten.


  1. Delete the Connection named Hotspot with the command nmcli connection delete Hotspot which was generated when Hotspot is turned on via GUI.


pratap@i7-6550u:~$ nmcli connection show
NAME         UUID                                  TYPE  DEVICE 
Sri Nilayam  cd93d019-2bbb-4b6f-aa80-b4536a563aa0  wifi  wlp2s0 
Hotspot      480fdd31-fe20-4b3d-8698-f25ec7678c1b  wifi  --     
pratap@i7-6550u:~$ nmcli connection delete Hotspot
Connection 'Hotspot' (480fdd31-fe20-4b3d-8698-f25ec7678c1b) successfully deleted.
  1. create Hotspot with the below command, you can explore various options from man nmcli command in a new terminal. Put your preffered values for ssid and password.

nmcli device wifi hotspot ssid myawesomehotspot password 12345678

enter image description here

  1. Never use GUI for turning on and off the Hotspot. If you use GUI to turn on, it again takes the name from system Device name. To turn on and off, use below commands.


nmcli connection up Hotspot
nmcli connection down Hotspot

enter image description here

As long as you dont use GUI way for Hotspot, it persists..

  • Although it's not a solution, at least I'm happy that you can confirm my finding. AND you've got a workaround. I applaud you because it enables me to continue my robotics project.. :-)
    – kramer65
    Apr 30, 2019 at 13:29
  • I'll will not select your answer as a solution though, because maybe someone else comes forward with the actual solution. Note that you made my week though!
    – kramer65
    Apr 30, 2019 at 13:30
  • I wish I could upvote this answer more than once. This was driving me nuts, too. Kudos for all the effort you put in to make it easy to follow!
    – Shaul Behr
    Jan 21, 2020 at 13:05

Another workaround: run nm-applet from console (or nm-applet & so that you can continue using that console for other commands). Then the good old wifi icon from Unity appears in your top bar, and if you activate the hotspot from there, it doesn't change the SSID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.