10

How to change display scaling settings in Lubuntu, so that the font, the icons and the buttons are bigger, similar to Mac OS X, in size?

enter image description here

1
  • 2
    Scaling is a known issue with LXQt - github.com/lxqt/lxqt-config/issues/401 @Andy's answer would require adding a fair amount of KDE (inc. KF5/KDE Frameworks) to your system, where LXQt (L=*light*) aims to be a light, and thus doesn't include it.
    – guiverc
    Dec 9, 2020 at 3:45

1 Answer 1

9

In Lubuntu 21.10, I had to go through the following steps:

  1. Open LXQt Configuration Center -> Session Settings -> Environment Variables (Advanced) or run lxqt-config-session
  2. Add QT_SCALE_FACTOR with value 2
  3. Add GDK_DPI_SCALE with value 2
  4. Add XCURSOR_SIZE with value 64

Screenshot of LXQt Session Settings showing the three additional environment variables

  1. Open LXQt Configuration Center -> Appearance -> Font and set Resolution (DPI) to 192

enter image description here

3
  • I can confirm that "this is the way". In my case, I have a stretch virtual display (for remote operation via smartphone) and played with scale values: decimals are allowed, GDK and QT doesn't have to be equals, for what is worth.
    – leoperbo
    Apr 19, 2022 at 3:00
  • Does this work for a laptop which has a HiDPI screen and then plugging in an external monitor that is not HiDPI? Meaning, is this scaling global, or per-display?
    – ahogen
    Feb 10, 2023 at 15:26
  • your screen shots are drop dead... Nov 30, 2023 at 20:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .