I updated my OS to Ubuntu 19.04, I had been using pgadmin4 on Ubuntu 18.10 and it worked without problems, now that I update I get this error:

"the application server could not be contacted"

I tried uninstalling pgadmin4 and reinstalling but without improvements ...

Also reactivate the postgresql repository because when updating to ubuntu 19.04 I deactivate some repositories

  • is your postgres server running? – JayEye Apr 21 '19 at 19:37

try How to Install and Configure pgAdmin4 on Ubuntu 18.04 & 16.04

remove the previous installation

sudo apt-get remove pgadmin4

and reinstall

sudo apt-get remove pgadmin4
 sudo apt-get install wget ca-certificates
 wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
 sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ `lsb_release -cs`-pgdg main" >> /etc/apt/sources.list.d/pgdg.list'
 sudo apt-get update
 sudo apt-get install pgadmin4 pgadmin4-apache2

for me it worked.

|improve this answer|||||

Just try from terminal :

$ pgadmin4

It will result just like this :

Python path:  "/usr/lib/python3/dist-packages" 
Python Home:  ""
Webapp path:  "/usr/share/pgadmin4/web/pgAdmin4.py"

If it doesn't work ,copy webapp path and You can start it manually:

$ sudo python3 /usr/share/pgadmin4/web/pgAdmin4.py
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.