11

I tried to install MySQL Workbench by:

 apt-get install mysql-workbench-community

But I get the following errors and I am unable to install it manually:

Depends: libssl1.0.0 (>= 1.0.2~beta3) but it is not installable
Depends: libzip4 (>= 0.10) but it is not installable

How can I install it?

1
  • 1
    You can also use DBeaver communty edition alternatively
    – Zombie
    Commented May 3, 2019 at 12:01

7 Answers 7

17

so this were the steps I took in order to install it correctly:

  1. Download the 2 Libraries that are needed and install them:

  2. Go to the MySQL Workbench Download Page and Download (At least for now) the latest version for Ubuntu 18.04 and install it. It should install correctly without any issues.

enter image description here

  1. Assuming you already installed the MySQL Client/Server packages, you should be able to see it like this now:

enter image description here

Note that as of the writing of this answer (April 25, 2019), the package mysql-workbench or mysql-workbench-community do not exist in the 19.04 repositories (Even with universe repositoy enabled). You can see here that there are not packages created yet: https://launchpad.net/ubuntu/disco/+source/mysql-workbench

6
  • 4
    (UNRELATED) How does it feel to have 64 GB ram?
    – Liso
    Commented Apr 25, 2019 at 15:31
  • 3
    @Emmet Solitaire lags less. Commented Apr 25, 2019 at 15:42
  • Thank you, this works perfectly. I got stuck on the piece where the first two links didn't actually start downloading. In case someone else is stuck on this - you actually have to pick one of the mirror links, which will start the download --> click on the downloaded file ---> install. Derp. Commented May 4, 2019 at 1:53
  • 1
    For me, I didn't need to install libssl, I just installed the libzip4 library and then workbench.
    – Jack M
    Commented Jun 20, 2019 at 14:31
  • @JackM thats awesome, it might mean that they are updating everything so it can be installed correctly in the future. Thank you Jack. Commented Jun 20, 2019 at 14:51
11

I solved this problem by installing the libzip package, directly from the deb package. I found at libzip4_1.1.2-1.1_amd64.deb.

Download and install libzip4, then install mysql-workbench from the apt or deb package, whichever you prefer.

5
  • 4
    But how can you install mysql-workbench on 19.04 when it is not available on apt??
    – Jay Chakra
    Commented Apr 25, 2019 at 10:43
  • 1
    Installing via deb gives a lot of dependency errors. On solving each one by one get stuck at libssl1.0.0
    – Jay Chakra
    Commented Apr 25, 2019 at 10:44
  • 1
    @JayChakra you have to set repositories by installing .deb package from https://dev.mysql.com/downloads/repo/apt or you have to install mysql-workbench .deb package manually. Commented Apr 25, 2019 at 15:04
  • 1
    This is what I was quoting above. Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: mysql-workbench-community : Depends: libssl1.0.0 (>= 1.0.2~beta3) but it is not installa
    – Jay Chakra
    Commented Apr 25, 2019 at 15:56
  • 2
    Anyways solution by @Luis Alvarado works for me.
    – Jay Chakra
    Commented Apr 25, 2019 at 16:02
3

Even if you check the download site (https://dev.mysql.com/downloads/workbench/), you don't see the released version for 19.04. Looks like we'll have to wait for the version to be released. That is totally a bummer.

Also I can confirm that the 18.10 installer doesn't work on the 19.04

2
  • Okay i was getting frustrated but now i just have to wait Commented Apr 23, 2019 at 3:47
  • By now they've added a 19.04 download on the official website.
    – Lode
    Commented Aug 11, 2019 at 20:28
2

my libzip4, libzip5 and libzip-dev are installed and have not resolved.

i solved this problem like this:

1-backup or remove these files: sudo rm /usr/local/lib/libcrypto.so.1.0.0 sudo rm /usr/local/lib/libssl.so.1.0.0

2-locate them in your system: sudo locate libcrypto.so.1.0.0 sudo locate libssl.so.1.0.0

3-recreate symbolic links for located them: sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/local/lib/libcrypto.so.1.0.0 sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /usr/local/lib/libssl.so.1.0.0

1

Just noticed that they took away the 18.10 installer from the download site. Not sure why. May be they're working on getting the 19.04 version out.

0

After installing these packages:

https://packages.ubuntu.com/cosmic/amd64/libssl1.0.0/download

https://packages.ubuntu.com/cosmic/amd64/libzip4/download

I installed python and it worked

sudo apt install python followed by sudo apt --fix-broken install and sudo apt update

I was able to install workbench designed for ubuntu 18.04 0n ubuntu 19.

0

I installed it by using: gdebi mysql-workbench-community_8.0.16-1ubuntu18.04_amd64.deb

It looks up dependencies and installs them, see http://manpages.ubuntu.com/manpages/bionic/man1/gdebi.1.html for more info

1
  • Gdebi isn't going to magically install the missing dependencies mentioned in the question. And what you installed is a different version, that works (also suggested in a commentary) but NOT because of Gdebi.
    – user880592
    Commented Jul 16, 2019 at 23:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .