0

I upgraded from 14.04->16.04->18.04 last weekend after holding out as long as possible until the end of 14.04 support, under the "it ain't broke..." approach.

Since the upgrade things have generally worked, but after one week, my windows suddenly lost their title-bars, I was unable to drag them, bring up the window menu, switch between desktops, etc.

I'm using the Gnome-Flashback desktop with Compiz. If I log in with metacity instead things work as expected. If, from within a terminal window on the metacity desktop I do a compiz --replace I see compiz start then core-dump just after loading the 'move' plugin. I've tried to delete ~/.compiz and ~/.cache/compiz, etc, but no joy.

Gnome-Flashback Compiz works fine for a secondary user on on the same laptop.

How can I reinitialise or generally otherwise fix compiz for my main user account?

2
  • You could try to use dconf-editor. Open org subfolder. Then right click on compiz and choose Reset recursively. Of course you will lose your compiz configuration. Did you do something before that started to happen? Apr 23, 2019 at 14:21
  • Thanks for the suggestion @muktupavels. I gave it a go, but as soon as I tried to change settings to restore extra desktop workspaces I got another crash, so I went with the purge suggestion answer and so far things seem to be working.
    – dfluff
    Apr 23, 2019 at 19:01

1 Answer 1

0

Purge Compiz. Run:

sudo apt purge gnome-panel gnome-session-flashback compiz compizconfig-settings-manager compiz-plugins
sudo apt autoremove
sudo apt purge $(dpkg -l | grep '^rc' | awk '{print $2}')

Reboot.

sudo apt install gnome-panel gnome-session-flashback compiz compizconfig-settings-manager compiz-plugin

Reboot.

Logout and Login to Gnome-Flashback Compiz.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .